[Mono-aspnet-list] Trying to install Mod Mono 1.1.13 on Apache 2.2 WinXP_SP2

Robert Jordan robertj at gmx.net
Fri Jul 3 06:17:12 EDT 2009

falcon_darkstar wrote:
> Hi all,
> I'm trying to get mod_mono 1.1.13 to work on my Windows machine running
> Apache2.2. The reason for this is cause I'm trying to develop a .Net 1.1
> website for an old Fedora box that has Apache 2.2 and Mono 1.1.13 installed.
> I've installed Apache 2.2, Mono and MonoDevelop. But I can't seem
> to find the files necessary to configure Apache to run mod-mono. There is no
> mod-mono.so and no mod-mono.conf.
> How do I configure this?

You don't want to configure this. Neither you want to run Mono 1.1.13
and definitely you don't even dream about wanting to run an old
mod_mono under Windows.

Live is too short to be spent on old distros, prehistoric Mono
versions and unsupported configurations ;)

This is what you want:

1) a parallel Mono 2.4 installation on the Linux box.
    See http://www.mono-project.com/Parallel_Mono_Environments
    You don't need root privileges for this.

2) If you can't change the apache's modules,
    you want to set a reverse proxy rule with mod_proxy
    and run xsp instead of mod_mono

3) a Mono 2.4 installation on Windows. Test with XSP.
    mod_mono might work as well, but it's too much work to IMO.


More information about the Mono-aspnet-list mailing list