[Mono-aspnet-list] SIGSEGV error, no idea why?

Marek Habersack grendel at twistedcode.net
Thu Jul 16 10:42:36 EDT 2009

Piercy wrote:
> The latest, And yeah i looked through my code and i cant find
> anything wrong.  i would of expected to have a asp.net error page if it was
> coming from my code, is this correct?  You will have to forgive me a little
> bit i am very new to mono and very new to asp .net coding.
Unfortunately, it can also happen if you have a recursion loop in your manged code. Mono doesn't 
handle that situation too well yet, alas. You can try to investigate that using the --trace 
parameter to the runtime (use xsp for testing, read man 1 mono). If it's a managed recursive call, 
you will be able to pick it up easily from the trace output. Just make sure to redirect the output 
to some file, as it will be really copious (and it will slow down your application significantly, 
but in this case it doesn't really matter).


> Thanks for your reply,
> Piercy
> Marek Habersack-6 wrote:
>> Piercy wrote:
>>> HI, i have an asp .net site i have been working on.  And recently after
>>> some
>>> changed i made i keep getting a 500 error loading the pages.  In the
>>> apache
>>> log i receive this: http://piercy.pastebin.com/f32b4a8f6.  Unfortunately,
>>> i
>>> still cannot figure out why i am getting this.  i am not sure what i even
>>> changed as far as i was aware i only changed some javascript code nothing
>>> to
>>> do with the actually asp.net/ c# code.  I checked an older version of the
>>> site and it runs so mono is still running and working ok. but i just cant
>>> figure out how to solve this issue.
>> It's a stack overflow, most likely an endless recursive call loop. What
>> version of Mono is that?
>> marek
>> _______________________________________________
>> Mono-aspnet-list mailing list
>> Mono-aspnet-list at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/mono-aspnet-list

More information about the Mono-aspnet-list mailing list