[Mono-dev] Feedback for Windows Forms in 1.1.15

Andreas Nahr ClassDevelopment at A-SoftTech.com
Tue Apr 18 15:02:19 EDT 2006

I tested some of my Winforms Apps on Mono 1.1.15 running on WinXP x64.
Most of the real-world apps didn't start, but some small sample ones did. 
Here are some notes about Problems with the ones that did:

Wrong clipping region/ Window size calculation? See screenshot

* Dividing line at wrong position -> should be at 50% of width of control.
* Readonly Elements not grayed out -> Gray out
* Readonly Elements show designers (if designers are used -> crash) -> Don't 
display designers for readonly elements
* Category Names not determined correctly if inherited -> Use inherited 
CategoryName Attributes
* Description default is currently: "Title<crlf>The long important 
Description" -> should be ""
* Default: All Entries expanded -> Should be: All entries NOT expanded
* Setting values does not work
* ToolbarVisible/HelpVisible ignored sometimes -> See screenshot

Crashes with any selection

Happy hacking!
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PropertyGrid.png
Type: image/png
Size: 36455 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20060418/25a4abc9/attachment.png 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Toolwindow.png
Type: image/png
Size: 15529 bytes
Desc: not available
Url : http://lists.ximian.com/pipermail/mono-devel-list/attachments/20060418/25a4abc9/attachment-0001.png 

More information about the Mono-devel-list mailing list