[Mono-dev] mod_mono on Solaris 8 - signal Bus Error (10)

Calin Cirstea calin.cirstea at saguaronet.ro
Thu Apr 27 02:30:17 EDT 2006


I'm trying to use mod_mono on my Sparc Solaris 8 computer but unfortunately I'm not very successful.

I used 3 types of packages:

1. packages from blastwave - with Apache 1.3

2. latest xsp and mod_mono sources from mono-project site - with Apache 2.0

3. latest SVN version of xsp and mod_mono - with Apache 2.0

The sources compiles OK.

Unfortunately I am always receiving the same:

"child pid xxx exit signal Bus Error (10)"

inside Apache error_log

If I try to run mod-mono-server, I receive another strange error:

"mod_mono and xsp have different versions."

Do you have any idea what I'm missing? 

Other comments:

  a.. mono version 1.1.14 - it's a SVN version from 2 weeks ago

  b.. when I start apache I can see a new instance of mono started (ps -A) so I suppose the xsp starts. 

  c.. if I start the xsp (as a stand alone) I can run the tests provided by mono 

My believe is that it's a problem of socket communication between apache and xsp, but might be wrong.

Please let me know if any of you have some clue about this problem and how can I use Apache and mod_mono on my Sparc 8.

Best regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20060427/0afe1bca/attachment.html 

More information about the Mono-devel-list mailing list