<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
<HTML>
<HEAD>
<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">
<META NAME="Generator" CONTENT="MS Exchange Server version 5.5.2654.45">
<TITLE>Question about RPM files </TITLE>
</HEAD>
<BODY>

<P><FONT SIZE=2 FACE="Arial">Hi,</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">I've been following the Mono project since the very beginning and I'm excited a lot about it.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">I'm new in Linux -Red Hat 9- (I've been working with Microsoft Platform for 9 years).</FONT>
<BR><FONT SIZE=2 FACE="Arial">I've downloaded the mono-all.zip from the mono site. I've tried to install the rpm's and</FONT>
<BR><FONT SIZE=2 FACE="Arial">Most were successfully installed but I can't install some as shown next in the error list.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">I've tried by installing from source code, but also failed.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">Seems everything it's about dependencies, where can I get those files?.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">Thank you very much.</FONT>
</P>

<P><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gdk-sharp) &gt;= 1.0.0.0 is needed by gecko-sharp-0.5-2.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(glib-sharp) &gt;= 1.0.0.0 is needed by gecko-sharp-0.5-2.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtk-sharp) &gt;= 1.0.0.0 is needed by gecko-sharp-0.5-2.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; libgtkhtml3.0_4 is needed by gtk-sharp-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; gtk-sharp = 1.0-1.ximian.6.0 is needed by gtk-sharp-gapi-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gdk-sharp) &gt;= 1.0.0.0 is needed by gtksourceview-sharp-0.5-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(glib-sharp) &gt;= 1.0.0.0 is needed by gtksourceview-sharp-0.5-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gnome-sharp) &gt;= 1.0.0.0 is needed by gtksourceview-sharp-0.5-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtk-sharp) &gt;= 1.0.0.0 is needed by gtksourceview-sharp-0.5-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono-locale-mideast = 1.0-1.ximian.6.1 is needed by mono-complete-1.0-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono-locale-rare = 1.0-1.ximian.6.1 is needed by mono-complete-1.0-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono-locale-cjk = 1.0-1.ximian.6.1 is needed by mono-complete-1.0-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono-locale-other = 1.0-1.ximian.6.1 is needed by mono-complete-1.0-1.ximian.6.1</FONT>
<BR><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gconf-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gdk-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gecko-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(glade-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(glib-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gnome-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtk-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtkhtml-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; </FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtksourceview-sharp) &gt;= 1.0.0.1 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(monodoc) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(pango-sharp) &gt;= 1.0.0.0 is needed by monodevelop-0.5-1.ximian.6.2</FONT>
<BR><FONT SIZE=2 FACE="Arial">error: Failed dependencies:</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(atk-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gdk-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(glade-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(glib-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtk-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(gtkhtml-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
<BR><FONT SIZE=2 FACE="Arial">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; mono(pango-sharp) &gt;= 1.0.0.0 is needed by monodoc-1.0-1.ximian.6.0</FONT>
</P>

<P><B><FONT COLOR="#000080" SIZE=2 FACE="Arial">Miguel A. Figueroa</FONT></B>
</P>

<P><B><FONT COLOR="#000080" SIZE=2 FACE="Arial">Software Engineer</FONT></B>
<BR><B><FONT COLOR="#000080" SIZE=2 FACE="Arial">FileNet Group</FONT></B>
<BR><B><FONT COLOR="#000080" SIZE=2 FACE="Arial">GE Capital International Services</FONT></B>
</P>

<P><FONT COLOR="#000080" SIZE=1 FACE="Arial">T (915) 225-2500 ext 3013</FONT>
<BR><FONT COLOR="#000080" SIZE=1 FACE="Arial">F (915) 225-2600</FONT>
<BR><FONT COLOR="#000080" SIZE=1 FACE="Arial">E</FONT><U> </U><A HREF="mailto:miguel.figueroa@edmi.com"><U><FONT COLOR="#0000FF" SIZE=1 FACE="Arial">miguel</FONT></U><U></U></A><U></U><U></U><U><FONT COLOR="#0000FF" SIZE=1 FACE="Arial">.figueroa@edmi.com</FONT></U>
<BR><FONT COLOR="#000080" SIZE=1 FACE="Arial">P (915) 578-6542 (numeric)</FONT>
<BR><FONT COLOR="#000080" SIZE=1 FACE="Arial">P</FONT><U> </U><A HREF="mailto:9155786542@francispaging.com"><U></U><U><FONT COLOR="#0000FF" SIZE=1 FACE="Arial">9155786542@francispaging.com</FONT></U><U></U></A><U></U><U></U><FONT COLOR="#000080" SIZE=1 FACE="Arial"> (via email)</FONT>
<BR><U></U><A HREF="mailto:9155786542@francispaging.com"><U></U><U><FONT COLOR="#0000FF" SIZE=1 FACE="Arial">http://gecis.home.ge.com</FONT></U><U></U></A><U></U><U></U>
</P>

<P><B><I><FONT COLOR="#0000FF" SIZE=1 FACE="Arial">&quot;That's all folks&quot;</FONT></I></B><I></I>
</P>
<BR>

</BODY>
</HTML>