<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=windows-1252">
<META content="MSHTML 6.00.2800.1400" name=GENERATOR></HEAD>
<BODY style="MARGIN: 4px 4px 1px; FONT: 12pt Arial">
<DIV>I am sure everyone knew this already, but I thought this was sort of 
enlightening... This is an exchange on the F# group. So it appears that Mono 1.0 
is being used at least to verify compatibility.</DIV>
<DIV>&nbsp;</DIV>
<DIV>Richard Norman<BR><BR></DIV>
<DIV>======================</DIV>
<DIV>Hi Dominic,</DIV>
<DIV>&nbsp;</DIV>
<DIV>You should not need to recompile programs when moving to new versions 
of<BR>the .NET Framework.&nbsp; However as you know F# has its own binary 
writer,<BR>and it is possible that the binaries being written are not correct 
in<BR>some minor detail that means they are not operating correctly on 
later<BR>versions.&nbsp; I'll try a few examples myself, but please feel free to 
send<BR>any binaries that are no longer functioning correctly.</DIV>
<DIV>&nbsp;</DIV>
<DIV>I regularly recompile code with F# on v2.0 runtimes and haven't seen 
any<BR>problems.&nbsp; Were the binaries compiled with any exotic switches 
like<BR>--unverifiable?</DIV>
<DIV>&nbsp;</DIV>
<DIV>BTW recently I've been setting up a testing framework to make sure 
that<BR>F# and Abstract IL compile and work correctly on v1.0, v1.1, v2.0 
and<BR>Rotor v1.0, and hopefully Mono 1.0 as well.&nbsp; </DIV>
<DIV>&nbsp;</DIV>
<DIV>Thanks,<BR>Don</DIV>
<DIV>&nbsp;</DIV>
<DIV>-----Original Message-----<BR>From: <A 
href="mailto:bounce-fsharp-6488@list.research.microsoft.com">bounce-fsharp-6488@list.research.microsoft.com</A> 
<BR>[mailto:bounce-fsharp-6488@list.research.microsoft.com] On Behalf 
Of<BR>Renato Lenzi<BR>Sent: 02 July 2004 18:14<BR>To: F# List<BR>Subject: Re: F# 
broken on CLR v2.0.40607?</DIV>
<DIV>&nbsp;</DIV>
<DIV>&gt; I installed the latest public Framework SDK and 
redistributable<BR>&gt; (v2.0.40607, available with these 'Express' products 
[1]) and F#<BR>&gt; programs seem broken... They crash with a unhandled 
(native)<BR>&gt; exception. The same programs run fine on 1.1 (and did run fine 
on<BR>&gt; previous 2.0s.) Does anyone have any insight?<BR>&gt;<BR>&gt; Dominic 
Cooney<BR>&gt;<BR>&gt; [1] <A 
href="http://msdn.microsoft.com/express">http://msdn.microsoft.com/express</A> 
<BR>&gt;</DIV>
<DIV>&nbsp;</DIV>
<DIV>May be you have to compile your programs again. I had the same 
problem<BR>going<BR>from 1.0 to 1.1 version of the framework. Try and let us 
know.</DIV>
<DIV>&nbsp;</DIV>
<DIV>Best regards</DIV>
<DIV>&nbsp;</DIV>
<DIV>--Renato<BR><A href="http://www.rexlen.it">www.rexlen.it</A> </DIV>
<DIV>&nbsp;</DIV>
<DIV><BR>---<BR></DIV></BODY></HTML>