<html><head><meta name="qrichtext" content="1" /></head><body style="font-size:12pt;font-family:Arial">
<p></p>
<p>This could be related to this bug I submitted:</p>
<p></p>
<p>http://bugzilla.ximian.com/show_bug.cgi?id=73048</p>
<p></p>
<p>XSP didn't account for the extra linefeed that IE sends.  If you use firefox, everything should work fine (if this is indeed the problem).</p>
<p></p>
<p>This is now fixed, and should be in 1.1.5 (by looking at the date it was fixed - march 16th)</p>
<p></p>
<p>Hope this helps!,</p>
<p>Curtis.</p>
<p></p>
<p></p>
<p>On Wednesday 13 April 2005 08:24, Kevin Flanagan wrote:</p>
<p><span style="color:#008000">&gt; Hello - I've installed Mono 1.1.4 on XP Pro - am writing an ASP.NET app to</span></p>
<p><span style="color:#008000">&gt; run under .NET and Mono, so it's very helpful to be able to test both on</span></p>
<p><span style="color:#008000">&gt; the same OS. The app (quite simple at present) basically runs fine under</span></p>
<p><span style="color:#008000">&gt; Mono, after a couple of tweaks ... in fact, I'm likely to be joining the</span></p>
<p><span style="color:#008000">&gt; ranks of those with nothing but praise for Mono. The only problem I can't</span></p>
<p><span style="color:#008000">&gt; solve is getting 'Read failure' on *almost* every page postback (running</span></p>
<p><span style="color:#008000">&gt; XSP and using IE6 on the same XP machine). I've seen this referred to</span></p>
<p><span style="color:#008000">&gt; elsewhere (e.g.</span></p>
<p><span style="color:#008000">&gt; http://www.webtropy.com/articles/art16-mono.asp?MONO%20for%20Linux) but not</span></p>
<p><span style="color:#008000">&gt; on this list, nor with any suggested solution.</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt; The results in the browser look like this:</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt; Server error in '/' application</span></p>
<p><span style="color:#008000">&gt; Description: Error processing request.</span></p>
<p><span style="color:#008000">&gt; Error Message: HTTP 500.</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt; Stack Trace: System.IO.IOException: Read failure</span></p>
<p><span style="color:#008000">&gt; Server stack trace:</span></p>
<p><span style="color:#008000">&gt; in &lt;0x000b8&gt; System.Net.Sockets.NetworkStream:Read (byte[],int,int)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00017&gt; Mono.ASPNET.XSPWorker:Read (byte[],int,int)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0012e&gt; Mono.ASPNET.BaseRequestBroker:Read (int,int,byte[]&amp;)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00131&gt; (wrapper xdomain-dispatch) Mono.ASPNET.BaseRequestBroker:Read</span></p>
<p><span style="color:#008000">&gt; (object,byte[]&amp;,byte[]&amp;,int,int,byte[]&amp;)</span></p>
<p><span style="color:#008000">&gt; Exception rethrown at [0]:</span></p>
<p><span style="color:#008000">&gt; ---&gt; System.Net.Sockets.SocketException: Operation on non-blocking socket</span></p>
<p><span style="color:#008000">&gt; would blockin &lt;0x0006b&gt; System.Net.Sockets.Socket:Receive_nochecks</span></p>
<p><span style="color:#008000">&gt; (byte[],int,int,System.Net.Sockets.SocketFlags)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0005b&gt; System.Net.Sockets.Socket:Receive</span></p>
<p><span style="color:#008000">&gt; (byte[],int,int,System.Net.Sockets.SocketFlags)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0007b&gt; System.Net.Sockets.NetworkStream:Read (byte[],int,int)</span></p>
<p><span style="color:#008000">&gt; --- End of inner exception stack trace ---</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00211&gt; (wrapper xdomain-invoke) Mono.ASPNET.BaseRequestBroker:Read</span></p>
<p><span style="color:#008000">&gt; (int,int,byte[]&amp;)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0004b&gt; (wrapper remoting-invoke-with-check)</span></p>
<p><span style="color:#008000">&gt; Mono.ASPNET.BaseRequestBroker:Read (int,int,byte[]&amp;)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x000a5&gt; Mono.ASPNET.XSPWorkerRequest:ReadInput (byte[],int,int)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0001f&gt; Mono.ASPNET.XSPWorkerRequest:ReadEntityBody (byte[],int)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00252&gt; System.Web.HttpRequest:GetRawContent ()</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0005c&gt; System.Web.HttpRequest:ParseFormData ()</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00012&gt; System.Web.HttpRequest:get_Form ()</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00062&gt; System.Web.UI.Page:DeterminePostBackMode ()</span></p>
<p><span style="color:#008000">&gt; in &lt;0x0001a&gt; System.Web.UI.Page:InternalProcessRequest ()</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00095&gt; System.Web.UI.Page:ProcessRequest (System.Web.HttpContext)</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00225&gt; ExecuteHandlerState:Execute ()</span></p>
<p><span style="color:#008000">&gt; in &lt;0x00071&gt; StateMachine:ExecuteState</span></p>
<p><span style="color:#008000">&gt; (System.Web.HttpApplication/IStateHandler,bool&amp;)</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt; Can anyone suggest a solution?</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt; Thanks in advance for any help.</span></p>
<p><span style="color:#008000">&gt;</span></p>
<p><span style="color:#008000">&gt; Kevin Flanagan.</span></p>
<p></p>
</body></html>