<br><font size=2 face="sans-serif">Unfortunately both kinds of confusion
cannot be avoided through a single version number.</font>
<br>
<br><font size=2 face="sans-serif">The only way to express a &quot;feel&quot;
that Mono 1.x is getting very close to complete .NET 2.0 compatibility
(where it is not already) would be to number Mono as 1.8.x / 1.9.x as it
gets really close to feature complete.</font>
<br>
<br><font size=2 face="sans-serif">Whichever way you choose to solve the
version numbering issue I think it would be really good idea if the front
page of Mono maintained a brief summary table of the most recent 2 maybe
3 versions of Mono that indicates for each which version of .NET it is
closest to fully supporting, and which also indicates the main features
it adds or lacks relative to that version, imaginary example:</font>
<br>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; Mono
1.8.x = .NET 2.0 + xxx (3.5) - yyy (2.0) - zzz (1.1)</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; Mono
1.9.x = .NET 2.0 + xxx (3.5) + qqq (3.5) - yyy (2.0)</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; ...</font>
<br><font size=2 face="sans-serif">&nbsp; &nbsp; &nbsp; &nbsp; Mono
2.0.0 = .NET 2.0 + xxx (3.5) ... etc. but no longer any &quot;-&quot; on
any 2.0 feature</font>
<br>
<br><font size=2 face="sans-serif">That'd give developers a quick browse
to www.go-mono.com to find out the &quot;detail&quot; of version compatibility.</font>
<br>
<br>
<br><font size=2><tt>&gt; I think the only way to minimise confusion in
the developer population<br>
&gt; that does not keep up-to-date with the details of development on Mono<br>
&gt; is to let at least the major version track full .NET compatibility.<br>
&gt; That is, do not move to v2.x.x until at least .NET 2.0 can be fully<br>
&gt; supported, do not move to v3.x.x until at least .NET 3.0 can be fully<br>
&gt; supported and maybe even do not move to v3.5.x until .NET 3.5 is<br>
&gt; supported. <br>
<br>
This does not solve the confusion that we have today which is that<br>
developers assume that until we have Mono X.Y we wont support version X,<br>
which is not the case.<br>
</tt></font>
<br>
<DIV>------------------------------------------<BR>This e-mail is 
confidential.&nbsp; If you are not the intended recipient, any use, disclosure 
or copying of this document is unauthorised and prohibited.&nbsp; If you have 
received this document in error, please delete the email and notify me by return 
email or by phoning the NEMMCO Helpdesk on 1300 300 295.</DIV>