<br clear="all">Hello,<br><br>When I try <a href="http://ASP.NET">ASP.NET</a> Validators inside Update Panel they work except when I use them within Templates like in FormView. The following code looks problematic&nbsp; if it is in an UpdatePanel and you first submit&nbsp; invalidly&nbsp;&nbsp; then make it valid &amp; submit then make it again invalid&amp;submit it. It breaks up :
<br><br><br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp; &lt;asp:FormView runat=&quot;server&quot;&nbsp; ID=&quot;FormView1&quot; DataSourceId=&quot;AdminDataSource&quot; DefaultMode=&quot;Insert&quot;&gt; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;  <br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;InsertItemTemplate&gt;
<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp; &lt;asp:Label SkinId=&quot;form&quot; runat=&quot;server&quot; Text=&quot;Kullanıcı Adı:&quot; AssociatedControlId = &quot;UserNameTextBox&quot; /&gt;<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;asp:TextBox ID=&quot;UserNameTextBox&quot; ValidationGroup=&quot;a&quot;&nbsp; runat=&quot;server&quot; Text=&#39;&lt;%# Bind(&quot;UserName&quot;) %&gt;&#39;&gt;&lt;/asp:TextBox&gt;&lt;br/ &gt; &nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;  &nbsp;&nbsp;&nbsp; &lt;asp:Button ID=&quot;OkButton&quot; Text=&quot;Tamam&quot; SkinId=&quot;form&quot; CausesValidation=&quot;True&quot;&nbsp;&nbsp; CommandName=&quot;Insert&quot;&nbsp; RunAt=&quot;Server&quot; /&gt;
<br>&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&lt;asp:RequiredFieldValidator&nbsp; runat=&quot;server&quot; ControlToValidate=&quot;UserNameTextBox&quot; Display=&quot;Static&quot; EnableClientScript=&quot;true&quot;&gt;*&lt;/asp:RequiredFieldValidator&gt; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;  
<br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &lt;/InsertItemTemplate&gt;  <br>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &lt;/asp:FormView&gt;<br>&nbsp;&nbsp;&nbsp; <br><br>However it works if it is not in UpdatePanel or Validator is not in a Template.<br>