Hi,<br><br>I&#39;ve fixed a number of the issues you&#39;ve mentioned. The ones I haven&#39;t applied fixes for are listed below with explanations:<br>

<br>Resolved issues:<br>1, 2, 3, 4, 5, 9, 10, 11, 12<br><br>Unresolved issues:<br>6,  7, 8<br><br>6) (Package.LoadRelationships - operation not valid)<br>I can&#39;t replicate this issue.  Can you verify that it&#39;s still there and if so create a small testcase to demonstrate the issue<br>


<br>7) Duplicate [Content_Types].xml<br>I didn&#39;t apply the fix because this PackagePart should never be in the &#39;Parts&#39; dictionary. If you are seeing it in the dictionary, could you create a testcase which replicates the issue so that I can fix it.<br>


<br>8) content type is always application/xml<br>I have an NUnit test, PackagePartTest.CheckPartProperties () which tests content types are loaded correctly and the test is passing. Can you supply a testcase which demonstrates the issue?<br>
<br>I&#39;m just going to deal with your newer emails now.<br><br>Alan.<br><br>p.s. Thanks for the very detailed bug report. It was very easy to derive NUnit tests from your descriptions to prevent these issues from surfacing again.<br>
<br><div class="gmail_quote">

On Mon, Mar 16, 2009 at 10:52 AM, Alan McGovern <span dir="ltr">&lt;<a href="mailto:alan.mcgovern@gmail.com" target="_blank">alan.mcgovern@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">


Hi,<br><br>Great stuff! I&#39;m going to review this today and commit it if all goes well. If you have any more bugs, just fire an email to the mono-devel list (CC&#39;ed) in case I&#39;m not around to deal with them.<br>


<font color="#888888"><br>
Alan.</font><div><div></div><div><br><br><div class="gmail_quote">On Sun, Mar 15, 2009 at 12:22 AM, Yves Dhondt <span dir="ltr">&lt;<a href="mailto:yves.dhondt@gmail.com" target="_blank">yves.dhondt@gmail.com</a>&gt;</span> wrote:<br>


<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
<div>Hello,</div>
<div> </div>
<div>I worked a bit more on the thing and came up with several more bugs and fixes. I extended my original document to include those as well.</div>
<div> </div>
<div>With the current set of fixes, it is possible to open an existing Word 2007/2008 document with ReadWrite permission and close it again without corrupting it. I have not tested it on other types of packages (Excel, Powerpoint) but they should work as well.</div>





<div> </div>
<div>Regards,</div>
<div> </div><font color="#888888">
<div>Yves<br><br></div></font><div><div></div><div>
<div class="gmail_quote">On Sat, Mar 14, 2009 at 12:56 PM, Yves Dhondt <span dir="ltr">&lt;<a href="mailto:yves.dhondt@gmail.com" target="_blank">yves.dhondt@gmail.com</a>&gt;</span> wrote:<br>
<blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0px 0px 0px 0.8ex; padding-left: 1ex;">
<div>Hello,</div>
<div> </div>
<div>This is probably not the best way of bug reporting but I could not find any track on bugzilla for olive to submit this under. The included pdf contains the description and possible fixes I came across when trying to use the olive WindowsBase.dll.</div>





<div> </div>
<div>Note that I only fixed those things to work for my needs and in some cases, more in-depth testing might be required (especially in PackUriHelper.ResolvePartUri).</div>
<div> </div>
<div>If you have any questions, feel free to contact me.</div>
<div> </div>
<div>Regards,</div>
<div> </div><font color="#888888">
<div>Yves</div></font></blockquote></div><br>
</div></div></blockquote></div><br>
</div></div></blockquote></div><br>