<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
  </head>
  <body bgcolor="#ffffff" text="#000000">
    Hello,<br>
    <br>
    I'm new to Mono. I've tried to install it on OpenEmbedded/Angstrom
    using "opkg mono" but I got 4 warnings about symbolic links not
    created:<br>
    * extract_archive: Cannot create symlink from
    ../gac/Mono.CompilerServices.SymbolWriter/2.0.0.0__0738eb9f132ed756/Mono.CompilerServices.SymbolWriter.dll
    to
    '../gac/Mono.CompilerServices.SymbolWriter/2.0.0.0__0738eb9f132ed756/Mono.CompilerServices.SymbolWrit':
    No such file or directory.<br>
    &nbsp;* extract_archive: Cannot create symlink from
    ../gac/System.ComponentModel.DataAnnotations/3.5.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll
    to
    '../gac/System.ComponentModel.DataAnnotations/3.5.0.0__31bf3856ad364e35/System.ComponentModel.DataAnn':
    No such file or directory.<br>
    &nbsp;* extract_archive: Cannot create symlink from
    ../gac/Mono.CompilerServices.SymbolWriter/1.0.5000.0__0738eb9f132ed756/Mono.CompilerServices.SymbolWriter.dll
    to
    '../gac/Mono.CompilerServices.SymbolWriter/1.0.5000.0__0738eb9f132ed756/Mono.CompilerServices.SymbolW':
    No such file or directory.<br>
    &nbsp;* extract_archive: Cannot create symlink from
    ../gac/System.Runtime.Serialization.Formatters.Soap/1.0.5000.0__b03f5f7f11d50a3a/System.Runtime.Serialization.Formatters.Soap.dll
    to
    '../gac/System.Runtime.Serialization.Formatters.Soap/1.0.5000.0__b03f5f7f11d50a3a/System.Runtime.Seri':
    No such file or directory.<br>
    <br>
    It seems I'm hitting a 100 characters limit on the path name. I
    wanted to create the symbolic links myself: would that do the trick
    ?<br>
    <br>
    If yes, I'm not sure where exactly I need to create those symbolic
    links. After some browsing, here are the links I'm planning to
    create:<br>
    <ul>
      <li>/usr/lib/mono/<b>2.0</b>/Mono.CompilerServices.SymbolWriter.dll
        --&gt;/usr/lib/mono/gac/Mono.CompilerServices.SymbolWriter/<b>2.0</b>.../Mono.CompilerServices.SymbolWriter.dll</li>
      <li>/usr/lib/mono/<b>2.0</b>/System.ComponentModel.DataAnnotations.dll
        --&gt;/usr/lib/mono/gac/System.ComponentModel.DataAnnotations/<b>3.5</b>.../System.ComponentModel.DataAnnotations.dll</li>
      <li>/usr/lib/mono/<b>1.0</b>/Mono.CompilerServices.SymbolWriter.dll
        --&gt;/usr/lib/mono/gac/Mono.CompilerServices.SymbolWriter/<b>1.0</b>.../Mono.CompilerServices.SymbolWriter.dll</li>
      <li>/usr/lib/mono/<b>1.0</b>/System.Runtime.Serialization.Formatters.Soap.dll
        --&gt;/usr/lib/mono/gac/System.Runtime.Serialization.Formatters.Soap/<b>1.0</b>.../System.Runtime.Serialization.Formatters.Soap.dll</li>
    </ul>
    Do I have these right ?<br>
    <br>
    Thanks for your help.<br>
  </body>
</html>