Hi,<br>
<br>
I&#39;ve not seen anything like that myself, but I&#39;ll admit we haven&#39;t run 
NaCl Mono through many production level environments yet, so there may 
be something there that&#39;s been previously undetected.  <br>
<br>
However, we&#39;ve run embedded in Unity3D (their entire scripting engine 
uses Mono) and only had to modify some scripts to get rid of null 
exceptions and floating point errors (div by zero).  I&#39;ve also 
personally run gmcs.exe and the output from that compiler all embedded 
in a NaCl module (and have done the same thing with Microsoft&#39;s F# 
compiler).  And we pass all the tests in mono/mini/&#39;*.cs that we are 
designed to pass (minus hardware exceptions, really).<br>
<br>
Because we&#39;ve run successfully in these various environments, I would 
still not discount possible bugs in your code that could be overwriting 
memory.<br>
<br>
Can you provide more info?  Are you using my github fork, or are you 
using Mono 2.10 with my scripts? NaCl changes merged to 2.10 or HEAD 
might be less stable than elijahtaylor/mono on github currently.  I&#39;m 
assuming you&#39;re embedding mono in your executable, is that the case?  If
 so, can you possibly send me your driver code that sets up the 
environment and runs things?  What architecture are you running (32- or 
64-bit), and what OS?  Are you running your nexe in sel_ldr or as a PPAPI plugin 
inside of Chrome?  What do your linker options look like?  Sorry for the deluge of questions :)<br>
<br>
-Elijah<br>
<br>
<br><br><div class="gmail_quote">On Sat, Apr 2, 2011 at 9:24 AM, C.Rivlaldo <span dir="ltr">&lt;<a href="mailto:vladimir@neoaxisgroup.com">vladimir@neoaxisgroup.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">
Hello!<br>
<br>
Firstly I must say big thanks to Elijah again. I had successfully run a part<br>
of our C# code with Mono on NaCl.<br>
<br>
But occasionally I&#39;m finding some bugs with global variables in Mono, which<br>
value is equal 0xffffffff. For example:<br>
* assemly_search_hook in assembly.c,<br>
* global_codeman in mini.c.<br>
<br>
I think NaCl corrupts the values of variables during the initialization or<br>
during running application.<br>
<br>
May be somebody had this problem before?<br>
<font color="#888888"><br>
--<br>
View this message in context: <a href="http://mono.1490590.n4.nabble.com/PATCH-more-support-for-Google-Native-Client-tp3159583p3422375.html" target="_blank">http://mono.1490590.n4.nabble.com/PATCH-more-support-for-Google-Native-Client-tp3159583p3422375.html</a><br>

</font><div><div class="h5">Sent from the Mono - Dev mailing list archive at Nabble.com.<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</div></div></blockquote></div>