<br><div class="gmail_quote">On Thu, Apr 21, 2011 at 1:09 AM, Quandary <span dir="ltr">&lt;<a href="mailto:quandary82@hailmail.net">quandary82@hailmail.net</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">


  
    
    
  
  <div text="#000000" bgcolor="#ffffff">Probably it was removed because it doesn&#39;t work with ASE 15.5, which
    is the current version.<br>
    I tried it, and it just didn&#39;t work.<br></div></blockquote><div><br></div><div>We&#39;re using Sybase 15.5 and the database server apparently goes into backwards-compatibility mode depending on the capability flags that the driver sends, but in this compatibility mode, it does not support any features added after about version 12.5x.</div>
<div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div text="#000000" bgcolor="#ffffff">If you find a driver that works, let me know.<br>
    I wanted to try how compatible Sybase is with MS-SQL, since they
    have a common ancestor.<br></div></blockquote><div><br></div><div>I had that idea, too, and I&#39;ve seen it suggested in some pretty old forum postings and mail lists, but the protocols seem to have diverged too much over time because I haven&#39;t been able to get it working with either the Mono or .NET MS-SQL server drivers.  The jtds driver covers both servers because it does a lot of conditional processing based on both the jdbc connection string and packets returned from the server.</div>
<div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div text="#000000" bgcolor="#ffffff">
    Couldn&#39;t get Sybase to work with Ubuntu 10 (worked fine on 9), but
    10.10&#39;s anyway a desaster.<br>
    Looking forward to v11, coming April 28/29. Else I&#39;m switching back
    to good old Debian.<br></div></blockquote><div><br></div><div>So far, I&#39;ve only been working in .NET on Windows, but I&#39;ll try it in mono on linux if/when I get it working.</div><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;">
<div text="#000000" bgcolor="#ffffff">My understanding is that Sybase sells their .NET driver, but that
    only together with a support contract (&amp; accompanying download
    login) that you don&#39;t really need, and there is no telling whether
    that .NET driver works on Linux.<br></div></blockquote><div><br></div><div>We&#39;ve got a Sybase support contract, so I&#39;ve been able to test their .NET driver.  It works, but it is horribly slow.  It is slightly faster than their OLEDB driver in some cases and slower in others.  But I don&#39;t think it will ever work on linux because the Sybase <a href="http://ADO.NET">ADO.NET</a> driver is actually just a managed wrapper around their unmanaged windows driver.</div>
<div><br></div><div>I&#39;ll keep you informed if I&#39;m able to make any more progress with updating the mono driver to work with 12.5 and greater.</div><div><br></div><div><br></div><div>Cheers,</div><div><br></div><div>
Troy</div><div><br></div></div>