<p>You need a C# compiler to compile the mono C# compiler written in C#.<br>
So you need an existing mono install to compile a newer version.</p>
<p>There&#39;s documentation on the mono site for building another version and using it side by side with another.</p>