<html><head></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; ">Hi,<div><br></div><div>I have pulled the repositories:</div><div><br></div><div>- <a href="http://github.com/mono/llvm.git">http://github.com/mono/llvm.git</a></div><div>- <a href="http://github.com/mono/">http://github.com/mono/</a></div><div><br></div><div>And am on the <b>mono-2.10 </b>branch of the mono git repo and the <b>mono </b>branch&nbsp;of the llvm git repo. &nbsp; The build proceeded smoothly until attempting to build the LLVM backend mapping in mono/mini:</div><div><br></div><div><div><span class="Apple-tab-span" style="white-space:pre">        </span>make[1]: Entering directory `/home/jshore/Srcs/mono-src/mono/mono/mini'</div><div><span class="Apple-tab-span" style="white-space:pre">        </span>CC<span class="Apple-tab-span" style="white-space:pre">        </span>mini-llvm-cpp.lo</div><div><span class="Apple-tab-span" style="white-space:pre">        </span>mini-llvm-cpp.cpp:42:41: fatal error: llvm/Support/StandardPasses.h: No such file or directory</div></div><div><br></div><div>I cannot find&nbsp;StandardPasses.h anywhere in either tree. &nbsp; Perhaps there is either a file missing for checkin in the repositiory or this file needs to get generated somehow? &nbsp; I did the configure for mono with the flag --enable-llvm.</div><div><br></div><div>Is there a problem with the sources in these repos or is there a build step that generates the missing header?</div><div><br></div><div>Thanks</div><div>Jonathan</div></body></html>