<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div id="IDstID">Your output "looks" the same to me. <br>
      <br>
      I'd think you need to normalize the strings before comparing them,
      something like:<br>
      <br>
      <pre wrap=""><tt>     if (!infos[0].Name.Normalize().Equals(UnicodeDirName.Normalize(), StringComparison.OrdinalIgnoreCase))
     {
</tt></pre>
      <br>
      Eberhard<br>
      <br>
      Jared Watts wrote on 2012-03-12 at 20:11 +0100:<br>
    </div>
    <blockquote
cite="mid:84DD5FE37A599D439AFD71AD5F760AA070340648@EXMBX08.netplexity.local"
      type="cite">
      <meta http-equiv="Content-Type" content="text/html;
        charset=ISO-8859-1">
      <meta name="Generator" content="Microsoft Word 14 (filtered
        medium)">
      <style><!--
/* Font Definitions */
@font-face
        {font-family:"MS Gothic";
        panose-1:2 11 6 9 7 2 5 8 2 4;}
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
@font-face
        {font-family:"\@MS Gothic";
        panose-1:2 11 6 9 7 2 5 8 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML Preformatted Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:Consolas;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
span.HTMLPreformattedChar
        {mso-style-name:"HTML Preformatted Char";
        mso-style-priority:99;
        mso-style-link:"HTML Preformatted";
        font-family:Consolas;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
      <div class="WordSection1">
        <p class="MsoNormal">I opened <a moz-do-not-send="true"
            href="https://bugzilla.xamarin.com/show_bug.cgi?id=3860">bug
            3860</a> earlier today, but I’m curious if anyone on the dev
          list has run into a similar issue or knows of a workaround.<o:p></o:p></p>
        <p class="MsoNormal"><a moz-do-not-send="true"
            href="https://bugzilla.xamarin.com/show_bug.cgi?id=3860">https://bugzilla.xamarin.com/show_bug.cgi?id=3860</a><o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Basically, on Mac OS X,
          Directory.CreateDirectory is used to create a sub directory
          with Unicode chars in the path (<span
            style="font-family:"MS Gothic"">ベートーヴェン</span>). 
          When that directory is retrieved with
          DirectoryInfo.GetFileSystemInfos, the Name property is
          different than what it was created with.<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">The attached .out file has the output from
          the sample repro program after it was run on Mac OS X.<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">If you want to build the attached repro
          program:<o:p></o:p></p>
        <p class="MsoNormal">csc /t:exe /out:UnicodeFileRepro.exe
          Program.cs<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">Thanks for any debugging ideas/workarounds!<o:p></o:p></p>
        <p class="MsoNormal"><o:p> </o:p></p>
        <p class="MsoNormal">- jared<o:p></o:p></p>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Mono-devel-list mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a>
<a class="moz-txt-link-freetext" href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a>
</pre>
    </blockquote>
  </body>
</html>