<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    I probably shouldn't cross-post, but i wasn't sure where to put
    this, or if i should file a bug report (I'm new-ish to mono).  After
    reading the mailing list description, this seemed like a more
    appropriate place to ask.<br>
    <br>
    First, let me say this is not a critical problem, and i'm not sure
    whether it is a bug on mono or not.  I might be interested in trying
    to fix this myself if i can figure out where to start (later), just
    as a time waster project.<br>
    <br>
    When I create an SqlConnection called, say, MyConnection, and then
    call MyConnection.Open() - the second time i call it (though the
    first time with each new object it is called on) with an invalid
    login name/password, it fails with what appears to be an exception
    message that implies something was null when it shouldn't have been
    (object reference not set to instance of an object).  If i call it
    with a valid login name/password on any attempt, it doesn't raise
    any errors, as is expected.<br>
    <br>
    From what i can tell, this is happening inside of
    MyConnection.Open() ... and not in my code.  I've verified that
    MyConnection is not null when i call Open().<br>
    <br>
    If you want to see sample code, i'll point you to my other post on
    this topic:<br>
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-1">
    <a
href="http://stackoverflow.com/questions/10355669/using-system-data-sqlconnection-in-mono-second-invalid-login-attempt-results-in">http://stackoverflow.com/questions/10355669/using-system-data-sqlconnection-in-mono-second-invalid-login-attempt-results-in</a>
    <br>
    <br>
    Does this sound like something i should file a bug on?  Also, if i'm
    interested in contributing, would it be wisest to file a bug first,
    then attempt to resolve it?<br>
    <br>
    -Rob<br>
  </body>
</html>