<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <br>
    Does anyone know: Is WPF Considered "open" like .net is, or is the
    fact that "W" stands for Windows in it mean that it is inherently
    closed..<br>
    <br>
    Incidentally, i was just looking at Visual Studio 2010 (not 2012,
    haven't tried it yet) last night and i noticed the default project
    type is still Winforms, WPF is secondary on the list.<br>
    <br>
    I wonder if the new Metro style apps in windows 8 means microsoft is
    going in yet another direction post-wpf.<br>
    <br>
    -Rob<br>
    <br>
    On 06/08/2012 10:19 PM, Steven Boswell II wrote:
    <blockquote
      cite="mid:1339208343.17150.YahooMailNeo@web160406.mail.bf1.yahoo.com"
      type="cite">
      <div style="color:#000; background-color:#fff; font-family:times
        new roman, new york, times, serif;font-size:12pt">
        <div><span>Well, that sample ran fine on my side, so I guess we
            have a problem.  Any idea how to resolve this issue?</span></div>
        <div><span><br>
          </span></div>
        <div><span>Re: using themes...sure, that's a long-term solution,
            but since mono-winforms is no longer officially supported,
            and Microsoft has moved on to WPF, I'd say the chances of
            this happening are between slim and none.  Still...enclosed
            is a newer version of the same patch, one that
            uses ThemeEngine.Current.ColorGrayText instead.</span></div>
        <div><span><br>
          </span></div>
        <div><span>Please let me know if there's anything else I need to
            do on this bug, especially since it's a visual change &
            so it's pretty much impossible to make a unit test for it.</span></div>
        <div><span><br>
          </span></div>
        <div><span>BTW, I couldn't find any bug reports for this issue.</span></div>
        <div><span><br>
          </span></div>
        <div><span>Steven Boswell</span></div>
        <div><br>
        </div>
        <div style="font-size: 12pt; font-family: 'times new roman',
          'new york', times, serif; ">
          <div style="font-size: 12pt; font-family: 'times new roman',
            'new york', times, serif; ">
            <div dir="ltr"> <font face="Arial" size="2">
                <hr size="1"> <b><span style="font-weight:bold;">From:</span></b>
                Stifu <a class="moz-txt-link-rfc2396E" href="mailto:stifu@free.fr"><stifu@free.fr></a><br>
                <b><span style="font-weight: bold;">To:</span></b>
                <a class="moz-txt-link-abbreviated" href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a> <br>
                <b><span style="font-weight: bold;">Sent:</span></b>
                Thursday, June 7, 2012 11:13 PM<br>
                <b><span style="font-weight: bold;">Subject:</span></b>
                Re: [Mono-dev] Patches for mono-winforms<br>
              </font> </div>
            <br>
            The one solution I uploaded doesn't have the hang, but it
            has the<br>
            never-called event handler.<br>
            I haven't tried anything else since then.<br>
            <br>
            I did notice issues with the disabled look of some controls,
            too (probably<br>
            have some related bug reports still up on Novell bugzilla).
            I think this<br>
            should all be handled within System.Windows.Forms.Theming,
            but it's not<br>
            always the case with existing code. Ideally, we should
            gradually move<br>
            theme-related code from System.Windows.Forms to<br>
            System.Windows.Forms.Theming. Just saying that for the
            information, not<br>
            saying we should do both fixing and moving things in the
            same patch.<br>
            <br>
            <br>
            Steven Boswell II wrote<br>
            > <br>
            > Stifu, did you have any better luck running your
            DgwTest, or my patch #1,<br>
            > successfully?  I was never able to reproduce the hang
            you described.<br>
            > <br>
            > I will hopefully have time and energy this weekend to
            write unit tests for<br>
            > more of the patches I sent earlier.<br>
            > <br>
            > I want to fix the appearance of disabled ListBox
            controls -- currently,<br>
            > they don't look any different than enabled ListBox
            controls.  Digging<br>
            > around the other controls, it seems that most of them
            simply draw the text<br>
            > with the GrayText color, they don't do anything fancier
            than that to<br>
            > implement the disabled look.  Enclosed is a patch that
            does that for<br>
            > ListBox.  If you know of a better way to accomplish
            this effect, I'm all<br>
            > ears.<br>
            > <br>
            > Steven Boswell<br>
            > <br>
            > _______________________________________________<br>
            > Mono-devel-list mailing list<br>
            > <a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@.ximian">Mono-devel-list@.ximian</a><br>
            > <a moz-do-not-send="true"
              href="http://lists.ximian.com/mailman/listinfo/mono-devel-list"
              target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            > <br>
            <br>
            --<br>
            View this message in context:
<a class="moz-txt-link-freetext" href="http://mono.1490590.n4.nabble.com/Patches-for-mono-winforms-tp4649620p4649781.html">http://mono.1490590.n4.nabble.com/Patches-for-mono-winforms-tp4649620p4649781.html</a><br>
            Sent from the Mono - Dev mailing list archive at Nabble.com.<br>
            _______________________________________________<br>
            Mono-devel-list mailing list<br>
            <a moz-do-not-send="true"
              ymailto="mailto:Mono-devel-list@lists.ximian.com"
              href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
            <a class="moz-txt-link-freetext" href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            <br>
            <br>
          </div>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Mono-devel-list mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a>
<a class="moz-txt-link-freetext" href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>