<html><head><meta content="text/html; charset=utf-8" http-equiv="Content-Type"></head><body><div><div style="font-family:Calibri,sans-serif;font-size:11pt">Hey,<br><br>I did report that and I also included a (temporary) patch for this (and possibly other)  issue, to make it build successfully.<br>
See one of my previous emails (I cant include a link or attachment right now as I'm not at home).<br><br>Matthias <br></div></div><hr><span style="font-family:Tahoma,sans-serif;font-size:10pt;font-weight:bold">Von: </span><span style="font-family:Tahoma,sans-serif;font-size:10pt">Robert Wilkens</span><br>
<span style="font-family:Tahoma,sans-serif;font-size:10pt;font-weight:bold">Gesendet: </span><span style="font-family:Tahoma,sans-serif;font-size:10pt">12.06.2012 05:49</span><br><span style="font-family:Tahoma,sans-serif;font-size:10pt;font-weight:bold">An: </span><span style="font-family:Tahoma,sans-serif;font-size:10pt">Jonathan Chambers</span><br>
<span style="font-family:Tahoma,sans-serif;font-size:10pt;font-weight:bold">Cc: </span><span style="font-family:Tahoma,sans-serif;font-size:10pt"><a href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a></span><br>
<span style="font-family:Tahoma,sans-serif;font-size:10pt;font-weight:bold">Betreff: </span><span style="font-family:Tahoma,sans-serif;font-size:10pt">Re: [Mono-dev] Win32 build errors (recent change)</span><br><br></body></html>
<html><head></head><body style="word-wrap:break-word">Awesome, just was hoping it wasn't my end. <div><br></div><div>-Rob</div><div><br><div><div>On Jun 11, 2012, at 11:44 PM, Jonathan Chambers wrote:</div><br class="Apple-interchange-newline">
<blockquote type="cite">Certain warning have been made into errors as the warnings are not safe on 64-bit builds. I am looking into fixing the build now.<div><br></div><div>Thanks,</div><div>Jonathan<br><br><div class="gmail_quote">
On Mon, Jun 11, 2012 at 9:23 PM, Rob Wilkens <span dir="ltr"><<a href="mailto:robwilkens@gmail.com" target="_blank">robwilkens@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">In my local copy of mono (robwilkens/mono on github) I can build in cygwin just fine...<br>
<br>
In the real mono/mono, i get the following error:<br>
<br>
In file included from ../../eglib/src/glib.h:7,<br>
                 from socket-io.c:20:<br>
/usr/i686-pc-mingw32/sys-root/<u></u>mingw/include/stdio.h:536: warning: no previous prototype for 'fopen64'<br>
/usr/i686-pc-mingw32/sys-root/<u></u>mingw/include/stdio.h:548: warning: no previous prototype for 'ftello64'<br>
socket-io.c: In function `ves_icall_System_Net_Sockets_<u></u>Socket_Available_internal':<br>
socket-io.c:835: warning: passing arg 3 of `ioctlsocket' from incompatible pointer type<br>
socket-io.c: In function `ves_icall_System_Net_Sockets_<u></u>Socket_Poll_internal':<br>
socket-io.c:1278: error: implicit declaration of function `time'<br>
.etc..<br>
<br>
Has there been recent build changes to Win32 building?<br>
<br>
-Rob<br>
______________________________<u></u>_________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com" target="_blank">Mono-devel-list@lists.ximian.<u></u>com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/<u></u>mailman/listinfo/mono-devel-<u></u>list</a><br>
</blockquote></div><br></div>
</blockquote></div><br></div></body></html>