<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <br>
    No problem, i think when the mono people (the officials) decided to
    leave winforms support to the community, they expected us to 'peer
    review' on some level too, not just code, so i figure i'm doing my
    part.<br>
    <br>
    -Rob<br>
    <br>
    On 06/16/2012 08:52 PM, Steven Boswell II wrote:
    <blockquote
      cite="mid:1339894368.68918.YahooMailNeo@web160401.mail.bf1.yahoo.com"
      type="cite">
      <div style="color:#000; background-color:#fff; font-family:times
        new roman, new york, times, serif;font-size:12pt">
        <div><span>
            <div>Thanks, Rob.  That's exactly what I expect would
              happen.  Only by building latest Mono, with the patch,
              will the project's test succeed with Mono.</div>
            <div><br>
            </div>
            <div>Don't worry about stretching your patience -- the fact
              that you got it to succeed in .NET was plenty helpful.</div>
            <div><br>
            </div>
            <div>Stifu..."<span style="font-size: 12pt; ">whether I
                build it with .NET or Mono, I get the error</span><span
                style="font-size: 12pt; "> I mentioned, running the
                application with Mono on Windows"...if you ran it with
                unpatched Mono, that's what I expect to happen.  If you
                ran it with patched Mono or with .NET, I wouldn't.  What
                exactly did you do?</span></div>
            <div><br>
            </div>
            <div>Steven Boswell</div>
          </span></div>
        <div><br>
        </div>
        <div style="font-size: 12pt; font-family: 'times new roman',
          'new york', times, serif; ">
          <div style="font-size: 12pt; font-family: 'times new roman',
            'new york', times, serif; ">
            <div dir="ltr"> <font face="Arial" size="2">
                <hr size="1"> <b><span style="font-weight:bold;">From:</span></b>
                Rob Wilkens <a class="moz-txt-link-rfc2396E" href="mailto:robwilkens@gmail.com"><robwilkens@gmail.com></a><br>
                <b><span style="font-weight: bold;">To:</span></b>
                <a class="moz-txt-link-abbreviated" href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a> <br>
                <b><span style="font-weight: bold;">Sent:</span></b>
                Saturday, June 16, 2012 5:41 PM<br>
                <b><span style="font-weight: bold;">Subject:</span></b>
                Re: [Mono-dev] Patches for mono-winforms<br>
              </font> </div>
            <br>
            As per the test project mentioned, I just tested with
            Microsoft Visual<br>
            Studio 2010 professional, on Windows 7, with Microsoft .NET
            (By clicking<br>
            Debug->Start Debugging to run it), this does not raise
            any exceptions<br>
            (no message box), it leaves me with an open window.  I also
            tested on<br>
            Mono on Windows (version 2.10.8) and the test fails in mono,
            seemingly<br>
            before a window is displayed on the screen.<br>
            <br>
            Again, i know my opinion is of mixed value.<br>
            <br>
            BTW - I did not try applying the patch in mono, i don't have
            the<br>
            patience right now (unless you want me to) to build mono in
            windows.<br>
            <br>
            -Rob<br>
            <br>
            <br>
            <br>
            On 06/16/2012 06:39 PM, Stifu wrote:<br>
            > I wasn't talking about the mailing list in particular,
            but any media<br>
            > (bugzilla, Git...). My point was that getting that many
            patches pushed<br>
            > within such a short time, for a part that is no longer
            maintained by the<br>
            > Mono team, is pretty good. I'd have been pretty happy
            if my patches received<br>
            > that much attention a few years ago.<br>
            ><br>
            > Anyway, about patch 2, whether I build it with .NET or
            Mono, I get the error<br>
            > I mentioned, running the application with Mono on
            Windows. So unless this is<br>
            > an OS-specific issue, I don't know what's the problem.
            I'll try to check it<br>
            > out on Linux, whenever I can find some time. Meanwhile,
            if anyone wants to<br>
            > review the patch, feel free.<br>
            ><br>
            ><br>
            > Steven Boswell II wrote<br>
            >> Are you saying that there have been bug fixes
            submitted to this mailing<br>
            >> list, that have sat around for YEARS without being
            acted upon by those<br>
            >> with version-control-commit authority...?<br>
            >><br>
            >> I installed latest mono to /usr/local, compiled my
            test with "gmcs<br>
            >> -out:DgvTest.exe <a moz-do-not-send="true"
              target="_blank" href="http://program.cs/">Program.cs</a>
            -r:System -r:System.Windows.Forms -r<br>
            >> System.Drawing", and ran it with "mono
            DgvTest.exe", and it runs fine for<br>
            >> me.  So I guess we're back to having an impasse. 
            Sigh.<br>
            >><br>
            >> Steven Boswell<br>
            >><br>
            >><br>
            >> ________________________________<br>
            >>  From: Stifu &lt;stifu@&gt;<br>
            >> To: <a class="moz-txt-link-abbreviated" href="mailto:mono-devel-list@.ximian">mono-devel-list@.ximian</a> <br>
            >> Sent: Saturday, June 16, 2012 1:09 AM<br>
            >> Subject: Re: [Mono-dev] Patches for mono-winforms<br>
            >>  <br>
            >> Honestly, you've had it much better than the vast
            majority. :)<br>
            >> Some others have been waiting for years. Also, now
            you can add NUnit to<br>
            >> your<br>
            >> resume. :p<br>
            >><br>
            >> Anyway, I get a "1-1: expected not null, found
            null" message box in<br>
            >> DgvTest4<br>
            >> with Mono, even after applying your patch.<br>
            >><br>
            >><br>
            >> Steven Boswell II wrote<br>
            >>> I agree, but we both know how much toil it
            takes to get our bug fixes<br>
            >>> accepted and applied to the git repository on
            this mailing list... ;-)<br>
            >>><br>
            >>><br>
            >>> ________________________________<br>
            >>>  From: Rob Wilkens &lt;robwilkens@&gt;<br>
            >>> To: <a class="moz-txt-link-abbreviated" href="mailto:mono-devel-list@.ximian">mono-devel-list@.ximian</a> <br>
            >>> Sent: Friday, June 15, 2012 5:42 PM<br>
            >>> Subject: Re: [Mono-dev] Patches for
            mono-winforms<br>
            >>>  <br>
            >>><br>
            >>> I know my opinion is of mixed value, but it
            looks to make sense to me.. <br>
            >>> If the toolstripitem is being changed so it no
            longer has an owner,<br>
            >>> calculating a size might not make sense....<br>
            >>><br>
            >>> -Rob<br>
            >>><br>
            >>> On 06/15/2012 08:34 PM, Steven Boswell II
            wrote: <br>
            >>> [... Digging through the stack trace, I arrived
            at<br>
            >>>
            System.Windows.Forms.ToolStripItem.set_InternalOwner, where
            the owner was<br>
            >>> being set to null, and right afterwards,
            CalculateAutoSize() was being<br>
            >>> called.  Why would anyone need to calculate the
            size of a menu-item that<br>
            >>> isn't even connected to a menu any more?  So,
            for me, the bug fix was<br>
            >>> obvious: check if the owner isn't null before<br>
            >>> calling CalculateAutoSize().<br>
            >>>  That's what the enclosed patch does. ...]<br>
            >>> _______________________________________________<br>
            >>> Mono-devel-list mailing list<br>
            >>> <a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@.ximian">Mono-devel-list@.ximian</a><br>
            >>> <a moz-do-not-send="true"
              href="http://lists.ximian.com/mailman/listinfo/mono-devel-list"
              target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            >>><br>
            >><br>
            >> --<br>
            >> View this message in context:<br>
            >>
<a class="moz-txt-link-freetext" href="http://mono.1490590.n4.nabble.com/Patches-for-mono-winforms-tp4649620p4649980.html">http://mono.1490590.n4.nabble.com/Patches-for-mono-winforms-tp4649620p4649980.html</a><br>
            >> Sent from the Mono - Dev mailing list archive at
            Nabble.com.<br>
            >> _______________________________________________<br>
            >> Mono-devel-list mailing list<br>
            >> <a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@.ximian">Mono-devel-list@.ximian</a><br>
            >> <a moz-do-not-send="true"
              href="http://lists.ximian.com/mailman/listinfo/mono-devel-list"
              target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            >> _______________________________________________<br>
            >> Mono-devel-list mailing list<br>
            >> <a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@.ximian">Mono-devel-list@.ximian</a><br>
            >> <a moz-do-not-send="true"
              href="http://lists.ximian.com/mailman/listinfo/mono-devel-list"
              target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            >><br>
            ><br>
            > --<br>
            > View this message in context: <a
              moz-do-not-send="true"
href="http://mono.1490590.n4.nabble.com/Patches-for-mono-winforms-tp4649620p4649989.html"
              target="_blank">http://mono.1490590.n4.nabble.com/Patches-for-mono-winforms-tp4649620p4649989.html</a><br>
            > Sent from the Mono - Dev mailing list archive at
            Nabble.com.<br>
            > _______________________________________________<br>
            > Mono-devel-list mailing list<br>
            > <a moz-do-not-send="true"
              ymailto="mailto:Mono-devel-list@lists.ximian.com"
              href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
            > <a moz-do-not-send="true"
              href="http://lists.ximian.com/mailman/listinfo/mono-devel-list"
              target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            <br>
            _______________________________________________<br>
            Mono-devel-list mailing list<br>
            <a moz-do-not-send="true"
              ymailto="mailto:Mono-devel-list@lists.ximian.com"
              href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
            <a moz-do-not-send="true"
              href="http://lists.ximian.com/mailman/listinfo/mono-devel-list"
              target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
            <br>
            <br>
          </div>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Mono-devel-list mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a>
<a class="moz-txt-link-freetext" href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a>
</pre>
    </blockquote>
    <br>
  </body>
</html>