<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    i was able to build no problem on windows when i applied my patch
    from yesterday<br>
    <br>
    First when i installed cygwin, i put all the development software
    (everything under i think it was devel)<br>
    <br>
    See
    <meta http-equiv="content-type" content="text/html;
      charset=ISO-8859-1">
    <a href="http://www.mono-project.com/Compiling_Mono_on_Windows">http://www.mono-project.com/Compiling_Mono_on_Windows</a>
    - you also need a path to an installed mono in order to build mono
    apparently, not sure if you already did that or not - that's also
    described on that page<br>
    <br>
    -Rob<br>
    <br>
    <br>
    On 06/17/2012 09:49 PM, Steven Boswell II wrote:
    <blockquote
      cite="mid:1339984177.21061.YahooMailNeo@web160404.mail.bf1.yahoo.com"
      type="cite">
      <div style="color:#000; background-color:#fff; font-family:times
        new roman, new york, times, serif;font-size:12pt">
        <div>I tried mightily to get latest Mono to build under MS
          Windows, starting with Rob's patch to help that along, and
          finally got stumped.  Attached are two patches, one with
          changes I know are good, and one with changes that shouldn't
          be necessary.</div>
        <div><br>
        </div>
        <div>It turns out I hadn't installed sed, and the Mono build
          scripts use sed liberally.  So one of the good patches is to
          add AC_PROG_SED to configure.in, so its existence is tested
          for.  (Modifying every reference to "sed" to use "$(SED)"
          instead is left to a future date. ;-)</div>
        <div><br>
        </div>
        <div>Does mcs recognize MS-Windows-style slash-prefixed options,
          or only Linux-style dash-prefixed options?  In my build, the
          slash-prefixed options ("/nologo", "/noconfig", and
          "/optimize") were being mistaken for pathnames.  The "hack"
          patch fixes two files, changing slash-options to dash-options.
           I didn't think this was necessary?</div>
        <div><br>
        </div>
        <div>Finally, my build died at "MCS [basic] System.Core.dll",
          because it couldn't find mscorlib.dll and System.dll .  The
          second section of my good patch
          modifies mcs/build/profiles/basic.make to look like the other
          profile makefiles, i.e. by adding
          "-lib:$(topdir)/class/lib/$(PROFILE)" to PROFILE_MCS_FLAGS.
           And both mcs/class/lib/basic/mscorlib.dll and
          mcs/class/lib/System.dll both exist.  But it didn't help; the
          build still dies there.  So I'm stumped.</div>
        <div><br>
        </div>
        <div>Has anyone else gotten further building Mono under MS
          Windows?</div>
        <div><br>
        </div>
        <div>Steven Boswell</div>
        <div><br>
        </div>
      </div>
      <br>
      <fieldset class="mimeAttachmentHeader"></fieldset>
      <br>
      <pre wrap="">_______________________________________________
Mono-devel-list mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a>
<a class="moz-txt-link-freetext" href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a>
</pre>
    </blockquote>
    \<br>
  </body>
</html>