We've been aware of such issues, could you file a bug and attach a test case with it please?<div><br></div><div>This would really really help us fix it.<br><br><div class="gmail_quote">On Wed, Jun 27, 2012 at 4:08 AM, Greg Young <span dir="ltr"><<a href="mailto:gregoryyoung1@gmail.com" target="_blank">gregoryyoung1@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">We are experiencing an issue with async behaviours in sockets (with<br>
SendAsync/callback not Begin/End).<br>
<br>
Our visible issue is that when in a send loop we will fail on our<br>
heartbeats. After debugging and counting calls into/out of<br>
SendAsync/callback we see that we are inside of a call to SendAsync<br>
(eg: it never returns, in our case for 10 seconds before we declare<br>
the socket dead). We can duplicate this fairly regularly on<br>
mac/bsd/linux though its nonconsistent (sometimes it may happen<br>
repeatedly other times it works fine). The code does not have such<br>
issues on MS CLR. We are also running on loopback so its unlikely that<br>
an underlying network problem is causing the hang up. The code itself<br>
is fairly straight forward (not that different than the MS example of<br>
the API except that its fully async (separate send/receive loops while<br>
the example is request/response))<br>
<br>
I am pulling sources now to build latest but does anyone happen to<br>
know of known issues with this sort of thing?<br>
<br>
Cheers,<br>
<br>
Greg<br>
<span class="HOEnZb"><font color="#888888"><br>
--<br>
Le doute n'est pas une condition agréable, mais la certitude est absurde.<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</font></span></blockquote></div><br></div>