I've just freshly built mono 2.11.4 from source using RHEL using <div><br></div><div>$ uname -a</div><div><div>Linux myhostname 2.6.32-279.el6.x86_64 #1 SMP Wed Jun 13 18:24:36 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux</div>
<div>$ gcc --version</div><div><div>gcc (GCC) 4.4.6 20120305 (Red Hat 4.4.6-4)</div></div><div><br></div><div>And all functionality seems to fail with the same System.TypeLoadException</div><div><br></div><div>$ mcs</div>
<div><br></div><div><div>Unhandled Exception:</div><div>System.TypeLoadException: Could not load type 'Mono.CSharp.CompilerSettings' from assembly 'mcs, Version=2.11.4.0, Culture=neutral, PublicKeyToken=null'.</div>
<div>  at Mono.CSharp.CommandLineParser..ctor (System.IO.TextWriter errorOutput) [0x00000] in <filename unknown>:0</div><div>  at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0</div>
<div>[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type 'Mono.CSharp.CompilerSettings' from assembly 'mcs, Version=2.11.4.0, Culture=neutral, PublicKeyToken=null'.</div><div>  at Mono.CSharp.CommandLineParser..ctor (System.IO.TextWriter errorOutput) [0x00000] in <filename unknown>:0</div>
<div>  at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0</div></div><div><br></div><div>The same happens whether running a "hello world" program, NUnit test, built-in applications, etc. Obviously something is configured or built incorrectly, but I am at a loss as to what, as the configure, make, and make install steps all ran without error. Where do I start looking?</div>
<div><br></div><div>Thanks,</div><div><br></div><div>Sebastian</div>
</div>