Just rediscovered the MONO_LOG_LEVEL="debug" environment variable. Here's the log from my app: <a href="http://sprunge.us/eXOV">http://sprunge.us/eXOV</a>. I think these might be related, but of course I could be totally wrong:<br>
Mono: The class System.Web.Http.Hosting.IHostBufferPolicySelector could not be loaded, used in System.Web.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35<div>Mono: The class System.Net.Http.HttpMessageInvoker could not be loaded, used in System.Net.Http, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a</div>
<div><br></div><div>Thoughts?<br><div><br></div><div><br><div class="gmail_quote">On Wed, Oct 24, 2012 at 2:23 PM, Daniel Lo Nigro <span dir="ltr"><<a href="mailto:lists@dan.cx" target="_blank">lists@dan.cx</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I'm trying to get <a href="http://ASP.NET" target="_blank">ASP.NET</a> WebApi working on Mono 3.0, and am getting<br>

the following error:<br>
<br>
System.TypeLoadException: Could not load type<br>
'System.Web.Http.WebHost.HttpControllerHandler' from assembly<br>
'System.Web.Http.WebHost, Version=4.0.0.0, Culture=neutral,<br>
PublicKeyToken=31bf3856ad364e35'.<br>
  at (wrapper managed-to-native) System.Type:type_is_assignable_from<br>
(System.Type,System.Type)<br>
  at System.Type.IsAssignableFrom (System.Type c) [0x00096] in<br>
/usr/local/src/mono-3.0.0/mcs/class/corlib/System/Type.cs:902<br>
  at System.Web.Mvc.AreaRegistration.IsAreaRegistrationType<br>
(System.Type type) [0x00000] in <filename unknown>:0<br>
  at System.Web.Mvc.TypeCacheUtil+<>c__DisplayClass1.<FilterTypesInAssemblies>b__0<br>
(System.Type type) [0x00000] in <filename unknown>:0<br>
  at System.Linq.Enumerable+<CreateWhereIterator>c__Iterator35`1[System.Type].MoveNext<br>
() [0x00059] in<br>
/usr/local/src/mono-3.0.0/mcs/class/System.Core/System.Linq/Enumerable.cs:3030<br>
  at System.Collections.Generic.List`1[System.Type].AddEnumerable<br>
(IEnumerable`1 enumerable) [0x00013] in<br>
/usr/local/src/mono-3.0.0/mcs/class/corlib/System.Collections.Generic/List.cs:134<br>
  at System.Collections.Generic.List`1[System.Type]..ctor<br>
(IEnumerable`1 collection) [0x0002f] in<br>
/usr/local/src/mono-3.0.0/mcs/class/corlib/System.Collections.Generic/List.cs:69<br>
  at System.Linq.Enumerable.ToList[Type] (IEnumerable`1 source)<br>
[0x00006] in /usr/local/src/mono-3.0.0/mcs/class/System.Core/System.Linq/Enumerable.cs:2867<br>
  at System.Web.Mvc.TypeCacheUtil.GetFilteredTypesFromAssemblies<br>
(System.String cacheName, System.Predicate`1 predicate, IBuildManager<br>
buildManager) [0x00000] in <filename unknown>:0<br>
  at System.Web.Mvc.AreaRegistration.RegisterAllAreas<br>
(System.Web.Routing.RouteCollection routes, IBuildManager<br>
buildManager, System.Object state) [0x00000] in <filename unknown>:0<br>
  at System.Web.Mvc.AreaRegistration.RegisterAllAreas (System.Object<br>
state) [0x00000] in <filename unknown>:0<br>
  at System.Web.Mvc.AreaRegistration.RegisterAllAreas () [0x00000] in<br>
<filename unknown>:0<br>
  at Daniel15.WebApiTest.WebApiApplication.Application_Start ()<br>
[0x00000] in <filename unknown>:0<br>
  at (wrapper managed-to-native)<br>
System.Reflection.MonoMethod:InternalInvoke<br>
(System.Reflection.MonoMethod,object,object[],System.Exception&)<br>
  at System.Reflection.MonoMethod.Invoke (System.Object obj,<br>
BindingFlags invokeAttr, System.Reflection.Binder binder,<br>
System.Object[] parameters, System.Globalization.CultureInfo culture)<br>
[0x000d5] in /usr/local/src/mono-3.0.0/mcs/class/corlib/System.Reflection/MonoMethod.cs:229<br>
<br>
Followed by this error:<br>
System.TypeLoadException:<br>
A type load exception has occurred.<br>
Description: HTTP 500.Error processing request.<br>
Details: Non-web exception. Exception origin (name of application or<br>
object): Daniel15.WebApiTest.<br>
<br>
Are there additional debug flags I can use to determine what's causing<br>
this and why it's unable to load the type? I'm using Mono 3.0<br>
(compiled from source) and xsp/fastcgi-mono-server4 (latest Git<br>
version)<br>
<br>
Thanks in advance!<br>
</blockquote></div><br><br></div></div>