Are you trying to build a newer mono with 2.10 era build scripts? I believe dmcs.exe/smcs.exe/gmcs.exe were removed and replaced with scripts. mcs.exe now can handle building against all profiles via the 'sdk' option. So, you may need to replace the failing line with a call to 'mcs.exe -sdk:4.0' or 'mcs.exe -sdk:4.5', if you cannot call the scripts directly.<div>
<br></div><div>Thanks,</div><div>Jonathan</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Nov 14, 2012 at 11:01 PM, Adam Baxter <span dir="ltr"><<a href="mailto:voltagex@voltagex.org" target="_blank">voltagex@voltagex.org</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi guys,<br>I'm trying to build mono from Git on Ubuntu with debuild and I'm getting errors at the last build-step.<br>
<br>>Cannot open assembly 'mcs/class/lib/net_4_0/dmcs.exe': No such file or directory.<br>

<br>The complete log is about 1.9mb. I've posted it at <a href="https://raw.github.com/gist/4076563/c87b7177d5ed691003442eed6a38b392ad310016/gistfile1.txt" target="_blank">https://raw.github.com/gist/4076563/c87b7177d5ed691003442eed6a38b392ad310016/gistfile1.txt</a> but if you want me to gzip it and post it to the list let me know.<br>

<br>The only changes I have made are to remove a debian symbol check step as the debian packaging files are out of date.<br><br>I also needed to use the monolite files to make the compile work at all<br><br>My build command was EXTERNAL_MCS="${PWD}/mcs/class/lib/monolite/gmcs.exe" debuild -j5 -b<br>

<br>Any ideas?<br><br>Thanks,<br>Adam Baxter<br>
<br>_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
<br></blockquote></div><br></div>