Looks like your MySQL credentials (username and password) might be wrong, and the error is occuring when it tries to retrieve the message for the error:<br><div class="gmail_quote"><div><br></div><div>...</div><div class="im">
<div><span style="font-family:arial,sans-serif;font-size:13px">/home/l/桌面/mono_src/mcs/class/</span><span style="font-family:arial,sans-serif;font-size:13px">corlib/System.Resources/</span><span style="font-family:arial,sans-serif;font-size:13px">ResourceManager.cs:252</span><br style="font-family:arial,sans-serif;font-size:13px">

<span style="font-family:arial,sans-serif;font-size:13px">  at MySql.Data.MySqlClient.</span><span style="font-family:arial,sans-serif;font-size:13px">Properties.Resources.get_</span><span style="font-family:arial,sans-serif;font-size:13px"><b><font color="#ff0000">AuthenticationFailed</font></b> ()</span><br style="font-family:arial,sans-serif;font-size:13px">

<span style="font-family:arial,sans-serif;font-size:13px">[0x00000] in <filename unknown>:0</span><br style="font-family:arial,sans-serif;font-size:13px"><span style="font-family:arial,sans-serif;font-size:13px">  at</span><br style="font-family:arial,sans-serif;font-size:13px">

<span style="font-family:arial,sans-serif;font-size:13px">MySql.Data.MySqlClient.</span><span style="font-family:arial,sans-serif;font-size:13px">Authentication.</span><span style="font-family:arial,sans-serif;font-size:13px">MySqlAuthenticationPlugin.</span><span style="font-family:arial,sans-serif;font-size:13px"><b><font color="#ff0000">AuthenticationFailed</font></b></span><br style="font-family:arial,sans-serif;font-size:13px">

<span style="font-family:arial,sans-serif;font-size:13px">(System.Exception ex) [0x00000] in <filename unknown>:0</span><br></div></div><div><span style="font-family:arial,sans-serif;font-size:13px">...</span></div>
<div><span style="font-family:arial,sans-serif;font-size:13px"><br>
</span></div><div><span style="font-family:arial,sans-serif;font-size:13px">Try checking that the username and password are valid.</span></div><div class="HOEnZb"><div class="h5"><div class="gmail_extra"><br><br><div class="gmail_quote">
On Fri, Dec 7, 2012 at 12:48 AM, lth3726381 <span dir="ltr"><<a href="mailto:lth3726381@gmail.com" target="_blank">lth3726381@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><br>
Hi :<br>
When i use the original package mono and mysql in ubuntu 11.04 ,everything<br>
is ok;<br>
but after i compiled the new mono source and run the program again,i got an<br>
exception:<br>
<br>
System.ArgumentNullException: Argument cannot be null.<br>
Parameter name: key<br>
  at System.Resources.ResourceManager.InternalGetResourceSet<br>
(System.Globalization.CultureInfo culture, Boolean createIfNotExists,<br>
Boolean tryParents) [0x0023c] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:439<br>
  at System.Resources.ResourceManager.InternalGetResourceSet<br>
(System.Globalization.CultureInfo culture, Boolean createIfNotExists,<br>
Boolean tryParents) [0x00209] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:430<br>
  at System.Resources.ResourceManager.InternalGetResourceSet<br>
(System.Globalization.CultureInfo culture, Boolean createIfNotExists,<br>
Boolean tryParents) [0x00209] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:430<br>
  at System.Resources.ResourceManager.GetString (System.String name,<br>
System.Globalization.CultureInfo culture) [0x0002e] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:252<br>
  at MySql.Data.MySqlClient.Properties.Resources.get_AuthenticationFailed ()<br>
[0x00000] in <filename unknown>:0<br>
  at<br>
MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.AuthenticationFailed<br>
(System.Exception ex) [0x00000] in <filename unknown>:0<br>
  at<br>
MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.ReadPacket<br>
() [0x00000] in <filename unknown>:0<br>
  at<br>
MySql.Data.MySqlClient.Authentication.MySqlAuthenticationPlugin.Authenticate<br>
(Boolean reset) [0x00000] in <filename unknown>:0<br>
  at MySql.Data.MySqlClient.NativeDriver.Authenticate (System.String<br>
authMethod, Boolean reset) [0x00000] in <filename unknown>:0<br>
  at MySql.Data.MySqlClient.NativeDriver.Open () [0x00000] in <filename<br>
unknown>:0<br>
  at MySql.Data.MySqlClient.Driver.Open () [0x00000] in <filename unknown>:0<br>
  at MySql.Data.MySqlClient.Driver.Create<br>
(MySql.Data.MySqlClient.MySqlConnectionStringBuilder settings) [0x00000] in<br>
<filename unknown>:0<br>
  at MySql.Data.MySqlClient.MySqlPool.CreateNewPooledConnection () [0x00000]<br>
in <filename unknown>:0<br>
  at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection () [0x00000] in<br>
<filename unknown>:0<br>
  at MySql.Data.MySqlClient.MySqlPool.TryToGetDriver () [0x00000] in<br>
<filename unknown>:0<br>
<br>
How to solve it ? Is this a bug?<br>
<br>
sorry 4 my bad English.<br>
<br>
lth<br>
<br>
<br>
<br>
--<br>
View this message in context: <a href="http://mono.1490590.n4.nabble.com/mysql-connector-ArgumentNullException-tp4657666.html" target="_blank">http://mono.1490590.n4.nabble.com/mysql-connector-ArgumentNullException-tp4657666.html</a><br>


Sent from the Mono - Dev mailing list archive at Nabble.com.<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com" target="_blank">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</blockquote></div><br></div>
</div></div></div><br>