<div dir="ltr">What version of the MySQL library are you using? I'm using <a href="http://nuget.org/packages/Mysql.Data">MySql.Data 6.5.4 from NuGet</a> and it's working for me on Mono 3.0.2.<div><br></div><div style>
My connection string looks like this:</div><div style><span style="color:rgb(51,51,51);font-family:Consolas,'Liberation Mono',Courier,monospace;font-size:12px;line-height:16px;white-space:pre">Server=10.0.2.1; Database=daniel15_dev; Uid=username; Pwd=password;</span><br>
</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Mon, Dec 10, 2012 at 12:46 AM, lth3726381 <span dir="ltr"><<a href="mailto:lth3726381@gmail.com" target="_blank">lth3726381@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Thanks 4 your reply:<br>
<br>
I tried the correct username and pwd,but there is another similar question:<br>
<div class="im"><br>
<br>
System.ArgumentNullException: Argument cannot be null.<br>
Parameter name: key<br>
  at System.Resources.ResourceManager.InternalGetResourceSet<br>
(System.Globalization.CultureInfo culture, Boolean createIfNotExists,<br>
Boolean tryParents) [0x0023c] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:439<br>
  at System.Resources.ResourceManager.InternalGetResourceSet<br>
(System.Globalization.CultureInfo culture, Boolean createIfNotExists,<br>
Boolean tryParents) [0x00209] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:430<br>
  at System.Resources.ResourceManager.InternalGetResourceSet<br>
(System.Globalization.CultureInfo culture, Boolean createIfNotExists,<br>
Boolean tryParents) [0x00209] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:430<br>
  at System.Resources.ResourceManager.GetString (System.String name,<br>
System.Globalization.CultureInfo culture) [0x0002e] in<br>
/home/l/桌面/mono_src/mcs/class/corlib/System.Resources/ResourceManager.cs:252<br>
</div>  at MySql.Data.MySqlClient.Properties.Resources.get_PerfMonCategoryName ()<br>
<div class="im">[0x00000] in <filename unknown>:0<br>
</div>  at MySql.Data.MySqlClient.PerformanceMonitor..ctor<br>
(MySql.Data.MySqlClient.MySqlConnection connection) [0x00000] in <filename<br>
unknown>:0<br>
  at MySql.Data.MySqlClient.MySqlConnection.Open () [0x00000] in <filename<br>
unknown>:0<br>
  at Tutorial1.Main () [0x00019] in /home/l/Projects/MySql/MySql/Main.cs:17<br>
Done.<br>
<br>
<br>
My connetion string is :<br>
string connStr =<br>
"server=localhost;user=root;database=exp;port=3306;password=l;";<br>
and I tried:<br>
string connStr = "Server=localhost;" + "Database=exp;" + "User ID=root;" +<br>
"Password=l;" + "Pooling=false";<br>
<br>
the user and password is correct.<br>
<br>
BTW , my program run corrected before I compiled the new mono source.<br>
<br>
<br>
<br>
--<br>
View this message in context: <a href="http://mono.1490590.n4.nabble.com/mysql-connector-ArgumentNullException-tp4657666p4657714.html" target="_blank">http://mono.1490590.n4.nabble.com/mysql-connector-ArgumentNullException-tp4657666p4657714.html</a><br>

<div class="HOEnZb"><div class="h5">Sent from the Mono - Dev mailing list archive at Nabble.com.<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</div></div></blockquote></div><br></div>