<!DOCTYPE html>
<html>
<head>
<title></title>
</head>
<body><div>I have more details on the bug.<br></div>
<div>The extra bytes that are at the beginning <br></div>
<pre class="lang-cs prettyprint prettyprinted"><code><span class="colour">31 </span><span class="pln"></span><span class="colour">39 </span><span class="pln"></span><span class="colour">36 </span><span class="pln"></span><span class="colour">62 </span><span class="pln"></span><span class="colour">36 </span><span class="pln"></span><span class="colour">38 </span><span class="pln"></span><span class="colour">0D </span><span class="pln"></span><span class="colour">0A</span></code><br></pre><div class="" defang_dir=""><code><span class="colour"></span><span class="pln"></span></code>which reads <span class="colour"><span class="font"><span class="size">196b68/r/n in ASCII</span></span></span><br></div>
<div><span class="colour">196b68 </span>is the filesize of the original image in hex...<br></div>
<div> </div>
<div>All details + hexdump links added here:<br></div>
<div><a href="http://stackoverflow.com/questions/14662795/why-do-i-have-unwanted-extra-bytes-at-the-beginning-of-image">http://stackoverflow.com/questions/14662795/why-do-i-have-unwanted-extra-bytes-at-the-beginning-of-image</a><br></div>
<div> </div>
<div> </div>
<div> </div>
<div>All traffic to that URL [<a href="http://www.daniel-steiger.ch">www.daniel-steiger.ch</a>] (except for the folders /doc and /images), but including images in /Content, is directly forwarded to fastcgi by nginx, as per fastcgi config file for domain.<br></div>
<div> </div>
<div> </div>
<div> server {<br></div>
<div>         listen   80;<br></div>
<div>         server_name <a href="http://www.daniel-steiger.ch">www.daniel-steiger.ch</a> daniel-steiger.ch;<br></div>
<div>         access_log   /var/log/nginx/daniel-steiger.ch.access.log;<br></div>
<div> </div>
<div>         location / {<br></div>
<div>                 root /home/danillo/www/HomePage;<br></div>
<div>                 #index index.html index.htm default.aspx Default.aspx;<br></div>
<div>                 #fastcgi_index Default.aspx;<br></div>
<div>                 fastcgi_pass 127.0.0.1:9000;<br></div>
<div>                 include /etc/nginx/fastcgi_params;<br></div>
<div>         }<br></div>
<div> </div>
<div> </div>
<div><span class="Apple-tab-span"></span>location /doc {<br></div>
<div><span class="Apple-tab-span"></span>root /usr/share;<br></div>
<div><span class="Apple-tab-span"></span>autoindex on;<br></div>
<div><span class="Apple-tab-span"></span>allow 127.0.0.1;<br></div>
<div><span class="Apple-tab-span"></span>deny all;<br></div>
<div><span class="Apple-tab-span"></span>}<br></div>
<div> </div>
<div><span class="Apple-tab-span"></span>location /images {<br></div>
<div><span class="Apple-tab-span"></span>root /usr/share;<br></div>
<div><span class="Apple-tab-span"></span>autoindex off;<br></div>
<div><span class="Apple-tab-span"></span>}<br></div>
<div> </div>
<div><span class="Apple-tab-span"></span>#error_page 404 /404.html;<br></div>
<div> </div>
<div><span class="Apple-tab-span"></span># redirect server error pages to the static page /50x.html<br></div>
<div><span class="Apple-tab-span"></span>#<br></div>
<div><span class="Apple-tab-span"></span>error_page 500 501 503 504 /50x.html;<br></div>
<div><span class="Apple-tab-span"></span>location = /50x.html {<br></div>
<div><span class="Apple-tab-span"></span>root /home/danillo/www/HomePage;<br></div>
<div><span class="Apple-tab-span"></span>}<br></div>
<div> </div>
<div> </div>
<div><span class="Apple-tab-span"></span>error_page 502 /502.html;<br></div>
<div><span class="Apple-tab-span"></span>location = /502.html {<br></div>
<div><span class="Apple-tab-span"></span>root /home/danillo/www/HomePage;<br></div>
<div><span class="Apple-tab-span"></span>}<br></div>
<div> </div>
<div>}<br></div>
<div> </div>
<div> </div>
<div>It's sufficient to have the file served without FileResult.</div>
<div>Of course it's more efficient if nginx serves it directly, but this is a very low traffic website, so performance is really not my problem ;)<br></div>
<div> </div>
<div>And by the way, the problem is not finding a workaround.<br></div>
<div> I have already fixed it with a workaround about a week ago.<br></div>
<div>I really just want to know where the bug is, because if FileResult malfunctions, there's probably more to it, and I don't want to walk into a subtle not at the first sight spottable bug later, like a botched binary upload/download file.</div>
<div> </div>
<div> </div>
<div> </div>
<div> </div>
<div> </div>
<div>On Sat, Feb 2, 2013, at 06:51 AM, Daniel Lo Nigro wrote:<br></div>
<blockquote class="QuoteMessage" type="cite"><div dir="ltr">Hmm... Maybe try an X-Accel-Redirect header instead. This lets Nginx serve the file instead of Mono having to serve it, which makes it more efficient. See if that makes a difference, or if it has the same issue.<div> </div>
<div style="">Why not just link directly to the file, instead of serving it through your C# code?<br></div>
</div>
<div class="gmail_extra"><div> </div>
<div> </div>
<div class="gmail_quote"><div>On Sun, Feb 3, 2013 at 1:43 AM, quandary82 <span dir="ltr"><<a href="mailto:quandary82@hailmail.net" target="_blank">quandary82@hailmail.net</a>></span> wrote:<br></div>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div>Corrected the mime, but seems to be a mono-bug (or fastcgi) anyway.<br></div>
<div> </div>
<div>
More here:<br></div>
<div><a href="http://stackoverflow.com/questions/14662795/why-do-i-have-unwanted-extra-bytes-at-the-beginning-of-image" target="_blank">http://stackoverflow.com/questions/14662795/why-do-i-have-unwanted-extra-bytes-at-the-beginning-of-image</a><br></div>
<div> </div>
<div> </div>
<div> </div>
<div>
--<br></div>
<div>
View this message in context: <a href="http://mono.1490590.n4.nabble.com/Bug-in-mono-3-0-1-MVC3-File-FileResult-tp4658382p4658422.html" target="_blank">http://mono.1490590.n4.nabble.com/Bug-in-mono-3-0-1-MVC3-File-FileResult-tp4658382p4658422.html</a><br></div>
<div>

Sent from the Mono - Dev mailing list archive at Nabble.com.<br></div>
<div class="HOEnZb"><div class="h5">_______________________________________________<br></div>
<div class="h5">
Mono-devel-list mailing list<br></div>
<div class="h5"><a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br></div>
<div class="h5"><a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br></div>
</div>
</blockquote></div>
</div>
</blockquote><div> </div>
<div class="signature sig3972393">-- <br></div>
<div class="signature sig3972393">  SirNoSkill<br></div>
<div class="signature sig3972393">  quandary82@hailmail.net<br></div>
<pre>
-- 
http://www.fastmail.fm - mmm... Fastmail...
</pre>
</body>
</html>