<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; "><div>I just did a new build of mono with llvm of the mono-3.0.7 tar ball.   I get the same problem with mono-sgen:</div><div><br></div><div><div>$ /opt/mono-3.0/bin/mono-sgen --profile=log:calls,output=profile.log,maxframes=10,calldepth=100 EAOutputEvaluator.exe ...</div><div>The 'log' profiler wasn't found in the main executable nor could it be loaded from 'mono-profiler-log'.</div></div><div><br></div><div>I had built mono with:</div><div><br></div><div><pre class="bash" style="font-size: 1em; background-color: rgb(248, 248, 248); border-width: 1px 1px 1px 5px; border-style: solid; border-color: rgb(221, 221, 221); padding: 5px; margin-right: 1em; margin-left: 1em; color: rgb(51, 51, 51); text-align: left; position: static; z-index: auto; ">.<span style="color: rgb(0, 0, 0); font-weight: bold;">/</span>autogen.sh <span style="color: rgb(102, 0, 51);">--prefix</span>=<span style="color: rgb(0, 0, 0); font-weight: bold;">/opt/mono-3.0</span> <span style="color: rgb(102, 0, 51);">--enable-llvm</span>=<span style="color: rgb(194, 12, 185); font-weight: bold;">yes</span></pre><div><br></div></div><div>It would seem that the 3.0.x builds are excluding the profiler ...</div><div><br></div><br><div><div>On Mar 18, 2013, at 4:34 PM, Alan <<a href="mailto:alan.mcgovern@gmail.com">alan.mcgovern@gmail.com</a>> wrote:</div><br class="Apple-interchange-newline"><blockquote type="cite">I believe the GC related profiling options, like allocation tracking<br>or heap-shot, only work with sgen. The performance related options<br>work irrespective of the GC being used.<br><br>Alan<br><br>On 18 March 2013 23:17, Andres G. Aragoneses <<a href="mailto:knocte@gmail.com">knocte@gmail.com</a>> wrote:<br><blockquote type="cite">On 18/03/13 22:57, Esben Laursen wrote:<br><blockquote type="cite"><br>Den 18-03-2013 20:59, Jonathan Shore skrev:<br><blockquote type="cite"><br>Hi,<br><br>I've used mono --profile… in the past with 2.10.x and did not have<br>problems in being able to run.    I was trying to run profiling on an<br>app again, this time with 3.0.x.   On both osx and linux, I get:<br><br>The 'log' profiler wasn't found in the main executable nor could it be<br>loaded from 'mono-profiler-log'.<br><br>I am using a standard build of mono 3.0.x on OSX and then my own build<br>on linux.   In the linux build configuration I saw that there is an<br>option to remove profiling from the build, but seemed that profiling<br>should be there by default.<br><br>Has profiling been removed as a default in the build?  And is there a<br>switch I can use to add this in?<br><br></blockquote><br>I have used it with a default build (on Linux though), but afaik is only<br>availble with sgen, did you try with mono-sgen or "mono --gc=sgen"<br><br>See <a href="http://www.mono-project.com/Profiler">http://www.mono-project.com/Profiler</a><br></blockquote><br><br>I've used it with the Boehm collector successfully.<br><br><br>_______________________________________________<br>Mono-devel-list mailing list<br><a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>http://lists.ximian.com/mailman/listinfo/mono-devel-list<br></blockquote>_______________________________________________<br>Mono-devel-list mailing list<br><a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>http://lists.ximian.com/mailman/listinfo/mono-devel-list<br></blockquote></div><br></body></html>