<div dir="ltr">The runtime is a mixture of LGPL and MIT and the BCL is mixture of MIT/X11 and compatible licenses such as the Microsoft variant of MIT.<div><br></div><div style>As the Debian guys found out there are some non-free files used to generate some files, but the byproduct is fine. This is for the AMQP driver, I believe. They are non-free because they cannot be changed even if they can be distributed freely.</div>
<div style><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, May 29, 2013 at 12:59 PM, Jeremy Bell <span dir="ltr"><<a href="mailto:bell.jeremy@gmail.com" target="_blank">bell.jeremy@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div><div>Thanks Rodrigo. Copying sounds like the way to go.<br><br><br></div>As an aside, this is for an open source project and the intent is to use the core mono runtime under the terms of the LGPL as stated in the licensing documentation. If there is any code in the mono repository that isn't dual licensed (in other words, commercial only, with no option for LGPL use), that needs to be made explicitly clear, as currently there is no mention of such in the licensing doc. <br>

<br></div>Regards,<br>Jeremy<br><div>
<br><br></div></div><div class="HOEnZb"><div class="h5"><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, May 29, 2013 at 12:22 PM, Rodrigo Kumpera <span dir="ltr"><<a href="mailto:kumpera@gmail.com" target="_blank">kumpera@gmail.com</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">There are no install target as those assemblies are not consumed in a standard way, it's very useful to have them on either the GAC or a profile directory.<div>

<br></div><div>What we do at Xamarin is to have them consumed as part of our product build, mostly due to historical reasons.</div>
<div><br></div><div>If you're using Xamarin.Android beta and have a paid license[1], you can copy them over. Yes, it's brittle, I'm sorry for that.</div><div><br></div><div>But it's something that should be fixed on the build system.</div>


<div><br></div><div>Cheers,</div><div>Rodrigo</div><div><br></div><div>[1]Starter edition doesn't allow random assemblies be used for the BCL.</div><div><br></div></div><div><div><div class="gmail_extra">

<br><br><div class="gmail_quote">On Wed, May 29, 2013 at 12:10 PM, Jeremy Bell <span dir="ltr"><<a href="mailto:bell.jeremy@gmail.com" target="_blank">bell.jeremy@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">


<div dir="ltr">Hmm, is there a separate install target that does install them? It's easy enough to copy the directory in a build script after make install, but that's a little brittle. Better that the build system handle that, I think.<br>



</div><div><div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, May 29, 2013 at 11:58 AM, Rodrigo Kumpera <span dir="ltr"><<a href="mailto:kumpera@gmail.com" target="_blank">kumpera@gmail.com</a>></span> wrote:<br>



<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Yes, it's not copied because those assemblies are not very useful on the desktop.</div><div class="gmail_extra">



<br><br><div class="gmail_quote"><div><div>On Wed, May 29, 2013 at 11:40 AM, Jeremy Bell <span dir="ltr"><<a href="mailto:bell.jeremy@gmail.com" target="_blank">bell.jeremy@gmail.com</a>></span> wrote:<br>

</div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div><div dir="ltr"><div>When I build the monodroid assemblies with the configure option --with-monodroid=yes, the profile is built correctly in the master branch, but when you make install, the monodroid profile assemblies are not copied to the install prefix directory with the other profiles. Is this expected behavior?<br>





<br></div>Here is my config options:<br><pre>./autogen.sh --with-glib<span>=</span>embedded --prefix<span>=</span><span>$INSTALL_PREFIX</span> --with-monodroid<span>=</span>yes<br></pre>
<pre>make && make install<br></pre></div>
<br></div></div>_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com" target="_blank">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
<br></blockquote></div><br></div>
</blockquote></div><br></div>
</div></div></blockquote></div><br></div>
</div></div></blockquote></div><br></div>
</div></div></blockquote></div><br></div>