<div dir="ltr">It was fixed in 10bcb9cf6975ec228e802587eb83df3e911f87a1 as iOS is always one step behind OSX when it comes to basic OS functionality.</div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Jun 26, 2013 at 10:28 AM, Martin Potter <span dir="ltr"><<a href="mailto:martin.potter@logos.com" target="_blank">martin.potter@logos.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



<div style="font-size:14px;font-family:Calibri,sans-serif;word-wrap:break-word">
<div>Per the commit message on <a href="https://github.com/mono/mono/commit/0542f8af71656fd318a83dac376576ff8ccab41d" target="_blank">
https://github.com/mono/mono/commit/0542f8af71656fd318a83dac376576ff8ccab41d</a> all of the build bots are now running Lion or Mountain Lion. As a result of being built on 10.7+ using the 10.7 (or 10.8) SDK, Mono will crash on Snow Leopard due to the lack of
 strndup. I submitted a pull request (<a href="https://github.com/mono/mono/pull/670" target="_blank">https://github.com/mono/mono/pull/670</a>) that avoids the detection of strndup on OS X so that strndup is not used.</div>

<div><br>
</div>
<div>Thanks,</div>
<div>Martin</div>
<div><br>
</div>
<span>
<div style="border-right:medium none;padding-right:0in;padding-left:0in;padding-top:3pt;text-align:left;font-size:11pt;border-bottom:medium none;font-family:Calibri;border-top:#b5c4df 1pt solid;padding-bottom:0in;border-left:medium none">

<span style="font-weight:bold">From: </span>Rodrigo Kumpera <<a href="mailto:kumpera@gmail.com" target="_blank">kumpera@gmail.com</a>><br>
<span style="font-weight:bold">Date: </span>Tuesday, June 25, 2013 6:33 PM<br>
<span style="font-weight:bold">To: </span>Martin Potter <<a href="mailto:martin.potter@logos.com" target="_blank">martin.potter@logos.com</a>><br>
<span style="font-weight:bold">Cc: </span>"<a href="mailto:mono-devel-list@lists.ximian.com" target="_blank">mono-devel-list@lists.ximian.com</a>" <<a href="mailto:mono-devel-list@lists.ximian.com" target="_blank">mono-devel-list@lists.ximian.com</a>><br>

<span style="font-weight:bold">Subject: </span>Re: [Mono-dev] Supported OS X versions for Mono 3.0<br>
</div><div><div class="h5">
<div><br>
</div>
<div>
<div>
<div dir="ltr">Mono 3.0 supports Snow Leopard.</div>
<div class="gmail_extra"><br>
<br>
<div class="gmail_quote">On Tue, Jun 25, 2013 at 2:26 PM, Martin Potter <<a href="mailto:martin.potter@logos.com" target="_blank">martin.potter@logos.com</a>> wrote:<br>
<blockquote class="gmail_quote">
<div>
<div>What is the minimum version of OS X that is planned to be supported by Mono for the 3.0 releases?</div>
<div><br>
</div>
<div>Thanks,</div>
<div>Martin</div>
</div>
<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com" target="_blank">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
<br>
</blockquote>
</div>
<br>
</div>
</div>
</div>
</div></div></span>
</div>

</blockquote></div><br></div>