<div dir="ltr"><div style>I have encountered a bug similar to <a href="https://bugzilla.xamarin.com/show_bug.cgi?id=4938" style="color:rgb(128,144,239);font-family:Verdana,sans-serif;background-color:rgb(204,204,255)">4938</a>.</div>
<div style><br></div><div style>My problem is that mono does not find the reference id because the id is in uppercase ('ID' instead of 'Id').  This works correctly on .NET.</div><div style><br></div><div style>
As stated in the bug description, the problem is in the SignedXml class, GetIdElement method.</div><div style><br></div><div style>I wrote a very simple patch that fixes the problem by looking for "id" and "ID".  Should I do a pull request with that fix?</div>
<br clear="all"><div><div dir="ltr"><b style="font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">Jonathan Gagnon</b><br style="color:rgb(136,136,136);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">
<span style="font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">Responsable des architectures systèmes</span><div><div>600, boulevard Armand-Frappier, bureau 200</div><div>Laval (Québec) H7V 4B4 </div>
<div>Canada</div><div><div>T : 450-662-6101 poste 234</div><div><font size="1"><a href="http://www.croesus.com" target="_blank"><img src="http://www.croesus.com/images/signature/Croesus-Logo.jpg"></a><br></font></div><div>
<a href="http://www.facebook.com/pages/Croesus-Finansoft/345020305606240" target="_blank"><img src="http://www.croesus.com/images/signature/facebook32.png"></a><a href="http://www.linkedin.com/company/croesus-finansoft?trk=hb_tab_compy_id_26141" target="_blank"><img src="http://www.croesus.com/images/signature/linkedin32.png"></a><a href="https://twitter.com/CroesusFin" target="_blank"><img src="http://www.croesus.com/images/signature/twitter32.png"></a><br>
</div><div><a></a><br></div></div></div></div></div>
</div>