<html dir="ltr">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style id="owaParaStyle" type="text/css">P {margin-top:0;margin-bottom:0;}</style>
</head>
<body ocsi="0" fpstyle="1">
<div style="direction: ltr;font-family: Tahoma;color: #000000;font-size: 10pt;">Hi,<br>
<br>
I have bumped in a bug with time zone date-time conversion (<a href="https://r2clr.codeplex.com/workitem/65" target="_blank">https://r2clr.codeplex.com/workitem/65</a> but I am pretty sure the underlying issue is e.g.<a href="https://bugzilla.xamarin.com/show_bug.cgi?id=1849" target="_blank">
 https://bugzilla.xamarin.com/show_bug.cgi?id=1849</a>)<br>
<br>
I'd like to see whether I can contribute a fix. I am used to test-driven development with VS2012, and would like to emulate this with MonoDevelop/Xamarin Studio on a Debian or Win box. I assume I cannot debug a Mono mscorlib with VS2012 but correct me otherwise.<br>
<br>
Rather than figure out a set up I'd welcome advice from core Mono contributors: how do you work, what's your software setup?<br>
<br>
I gave a couple hours trying/googling/doc reading but with limited results.<br>
- Got the latest 'master' source from GIT. autogen, make, sudo make install, fine. However an easy option to build and install the debug symbols along is not obvious.<br>
- Usually as soon as I compile/install mono from source, even a very recent (Debian unstable) MonoDevelop stops working (see below). Prior attempts to compile MD from source did not work out.<br>
<br>
$ monodevelop <br>
System.TypeInitializationException: An exception was thrown by the type initializer for Mono.Unix.Native.Syscall ---> System.EntryPointNotFoundException: Mono_Posix_Syscall_get_at_fdcwd<br>
<br>
Thanks in advance.<br>
<br>
</div>
</body>
</html>