<div dir="ltr">You are correct in assumption that this is the way soft debugger handles breakpoints (it generates segfault). One solution might be to attach visuals tudio debugger *after* breakpoint has been hit.<div><br></div>
<div>I'm interested in other ways, as well.</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On 1 August 2013 08:56, Jonathan Lima <span dir="ltr"><<a href="mailto:greenboxal@gmail.com" target="_blank">greenboxal@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Let's say I have an application running an embed mono and I'm debugging this application with VisualStudio.<div>
Also I have Monodevelop connected through the soft debugger on this embed mono instance.</div>
<div><br></div><div>When I set a breakpoint managed code on Monodevelop a native exception is thrown on VisualStudio(Access Violation Exception) and I can't debug both native and managed code on the same time. Probably this exception is how mono debugger manages breakpoints.</div>

<div><br></div><div>My question is, is there a way to debug the embed engine(and the rest of my native code) and the managed code at the same time?<br><br>Thanks for your time,</div><div>Jonathan Lima</div></div>
<br>_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
<br></blockquote></div><br></div>