<div dir="ltr">Hi,<div><br></div><div>  This is a JIT problem, it will be hard to track down without a testcase. You can try changing this line in mono/utils/mono-codeman.c:</div><div><br></div><div>#define BIND_ROOM 8</div>
<div><br></div><div>to</div><div><br></div><div>#define BIND_ROOM 4</div><div><br></div><div>It might fix the issue.</div><div><br></div><div>           Zoltan</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">
On Tue, Aug 13, 2013 at 7:44 AM, Bassam Tabbara <span dir="ltr"><<a href="mailto:bassam@symform.com" target="_blank">bassam@symform.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">




<div style="font-size:14px;font-family:Calibri,sans-serif;word-wrap:break-word">
<div>Folks,</div>
<div><br>
</div>
<div>Any insights into why the assert would trigger? Is this a resource exhaustion issue, or is specific to certain code that is being JITed? I need someone to point me in the right direction. I'm able to reproduce this but only in the context of our application.
 This did not happen with the mono-2-10 branch.</div>
<div><br>
</div>
<div>Thanks!</div>
<div>Bassam </div>
<div><br>
</div>
<span>
<div style="border-right:medium none;padding-right:0in;padding-left:0in;padding-top:3pt;text-align:left;font-size:11pt;border-bottom:medium none;font-family:Calibri;border-top:#b5c4df 1pt solid;padding-bottom:0in;border-left:medium none">

<span style="font-weight:bold">From: </span>Bassam Tabbara <<a href="mailto:bassam@symform.com" target="_blank">bassam@symform.com</a>><br>
<span style="font-weight:bold">Date: </span>Friday, August 9, 2013 10:36 AM<br>
<span style="font-weight:bold">To: </span>"<a href="mailto:mono-devel-list@lists.ximian.com" target="_blank">mono-devel-list@lists.ximian.com</a>" <<a href="mailto:mono-devel-list@lists.ximian.com" target="_blank">mono-devel-list@lists.ximian.com</a>><br>

<span style="font-weight:bold">Subject: </span>[Mono-dev] Assert in mini-arm.c<br>
</div>
<div><br>
</div>
<div>
<div style="font-size:14px;font-family:Calibri,sans-serif;word-wrap:break-word">
<div>Hello,</div>
<div><br>
</div>
<div>I'm seeing the following assert on an armv5tel using latest from master:</div>
<div><br>
</div>
<div><a href="http://pastebin.com/raw.php?i=CLDXxiPy" target="_blank">http://pastebin.com/raw.php?i=CLDXxiPy</a></div>
<div><br>
</div>
<div>I'm trying to get an isolated repro but it proving to be elusive. In our full test runs we see this all the time. </div>
<div><br>
</div>
<div>Any tips on how to debug this further? </div>
<div><br>
</div>
<div>Thanks!</div><span class="HOEnZb"><font color="#888888">
<div>Bassam</div>
</font></span></div>
</div>
</span>
</div>

<br>_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
<br></blockquote></div><br></div>