<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=Windows-1252">
</head>
<body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; color: rgb(0, 0, 0); font-size: 14px; font-family: Calibri, sans-serif; ">
<div>I donít see this problem when running with ĖO=-gshared. The application seems to runs slower however. Is there any other information I can provide to help resolve this? It only seems to be happening on ARM for me.</div>
<div><br>
</div>
<span id="OLK_SRC_BODY_SECTION">
<div style="font-family:Calibri; font-size:11pt; text-align:left; color:black; BORDER-BOTTOM: medium none; BORDER-LEFT: medium none; PADDING-BOTTOM: 0in; PADDING-LEFT: 0in; PADDING-RIGHT: 0in; BORDER-TOP: #b5c4df 1pt solid; BORDER-RIGHT: medium none; PADDING-TOP: 3pt">
<span style="font-weight:bold">From: </span>Zoltan Varga <<a href="mailto:vargaz@gmail.com">vargaz@gmail.com</a>><br>
<span style="font-weight:bold">Date: </span>Wednesday, August 14, 2013 4:54 PM<br>
<span style="font-weight:bold">To: </span>Bassam Tabbara <<a href="mailto:bassam@symform.com">bassam@symform.com</a>><br>
<span style="font-weight:bold">Cc: </span>"<a href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a>" <<a href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a>><br>
<span style="font-weight:bold">Subject: </span>Re: [Mono-dev] Non-sensical stack trace (possible issue with generic sharing?)<br>
</div>
<div><br>
</div>
<div>
<div>
<div dir="ltr">Hi,
<div><br>
</div>
<div>  Try running with -O=-gshared to see whenever this is a generic sharing problem. The stack trace might be missing the List.Add () method for some reason.</div>
<div><br>
</div>
<div>              Zoltan</div>
</div>
<div class="gmail_extra"><br>
<br>
<div class="gmail_quote">On Thu, Aug 15, 2013 at 1:29 AM, Bassam Tabbara <span dir="ltr">
<<a href="mailto:bassam@symform.com" target="_blank">bassam@symform.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div style="font-size:14px;font-family:Calibri,sans-serif;word-wrap:break-word">
<div>On an armv5tel with latest mono from master I see the following exception frequently in our automated test runs:</div>
<div><br>
</div>
<div>
<div>System.ArgumentOutOfRangeException: Value has to be >= 0.</div>
<div>Parameter name: destinationIndex</div>
<div>  at System.Array.Copy (System.Array sourceArray, Int32 sourceIndex, System.Array destinationArray, Int32 destinationIndex, Int32 length) [0x00207] in /root/build-thirdparty/mono/mcs/class/corlib/System/Array.cs:1016 </div>
<div>  at System.Collections.Generic.List`1[Symform.Control.Common.Placement.NodeEndPoint].CopyTo (Symform.Control.Common.Placement.NodeEndPoint[] array, Int32 arrayIndex) [0x00000] in /root/build-thirdparty/mono/mcs/class/corlib/System.Collections.Generic/List.cs:203 </div>
<div>  at Newtonsoft.Json.Utilities.CollectionWrapper`1[System.Object].Add (System.Object item) [0x00000] in <filename unknown>:0 </div>
<div>  at Newtonsoft.Json.Utilities.CollectionWrapper`1[System.Object].System.Collections.IList.Add (System.Object value) [0x00000] in <filename unknown>:0 </div>
<div>  at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.PopulateList (IWrappedCollection wrappedList, Newtonsoft.Json.JsonReader reader, Newtonsoft.Json.Serialization.JsonArrayContract contract, Newtonsoft.Json.Serialization.JsonProperty containerProperty,
 System.String id) [0x00000] in <filename unknown>:0 </div>
</div>
<div><br>
</div>
<div>Whats odd about this stack trace is that JsonSerializeInternalReader.PopulateList does not call CollectionWrapper`1.Add, nor does Add call List`1.CopyTo. See <a href="http://json.codeplex.com/SourceControl/latest#trunk/Src/Newtonsoft.Json/Utilities/CollectionWrapper.cs" target="_blank">http://json.codeplex.com/SourceControl/latest#trunk/Src/Newtonsoft.Json/Utilities/CollectionWrapper.cs</a>.</div>
<div><br>
</div>
<div>Is it possible that the stack trace is mangled, or is this a generic sharing problem?</div>
<div><br>
</div>
<div>Note I do not see this issue on x86 or amd64, and did not see this with mono-2-10 on all platforms.</div>
<div><br>
</div>
<div>Thanks!</div>
<span class="HOEnZb"><font color="#888888">
<div>Bassam</div>
</font></span></div>
<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
<br>
</blockquote>
</div>
<br>
</div>
</div>
</div>
</span>
</body>
</html>