<div dir="ltr"><span style="font-family:arial,sans-serif;font-size:13px">Hi,</span><div style="font-family:arial,sans-serif;font-size:13px"><br></div><div style="font-family:arial,sans-serif;font-size:13px">I'm trying to run tests against the .net runtime, to check that my patch produce the same output on the .net runtime. When I do make run-test-ondotnet, I get the following error;</div>

<div style="font-family:arial,sans-serif;font-size:13px"><br></div><div style="font-family:arial,sans-serif;font-size:13px"><div>$ make run-test-ondotnet</div><div>make run-test-ondotnet-local</div><div>make[1]: Entering directory '/home/Antoine/<span class="" style="background-color:rgb(255,255,204)">mono</span>/mcs/class/System.ServiceModel.Web'</div>

<div>ok=:; \</div><div>./../../class/lib/net_4_5/nunit-console.exe  System.ServiceModel.Web_test_net_4_5.dll -noshadow   /exclude:NotDotNet,CAS -output=TestResult-ondotnet-net_4_5.log -xml=TestResult-ondotnet-net_4_5.xml   || ok=false; \</div>

<div>(echo ''; cat TestResult-ondotnet-net_4_5.log) | sed '1,/^Tests run: /d'; xsltproc ./../../build/nunit-summary.xsl TestResult-ondotnet-net_4_5.xml >> TestResult-ondotnet-net_4_5.log ; $ok</div>
<div>
NUnit version 2.4.8</div><div>Copyright (C) 2002-2007 Charlie Poole.</div><div>Copyright (C) 2002-2004 James W. Newkirk, Michael C. Two, Alexei A. Vorontsov.</div><div>Copyright (C) 2000-2002 Philip Craig.</div><div>All Rights Reserved.</div>

<div><br></div><div>Runtime Environment -</div><div>   OS Version: Microsoft Windows NT 6.2.9200.0</div><div>  CLR Version: 4.0.30319.34003 ( Net 4.0.30319.34003 )</div><div><br></div><div><b>Could not load file or assembly 'nunit.framework, Version=2.4.8.0, Culture=neutral, PublicKeyToken=96d09a1eb7f44a77' or one of its dependencies. The system cannot find the file specified.</b></div>

<div>warning: failed to load external entity "TestResult-ondotnet-net_4_5.xml"</div><div>unable to parse TestResult-ondotnet-net_4_5.xml</div><div>../../build/tests.make:93: recipe for target 'run-test-ondotnet-lib' failed</div>

<div>make[1]: *** [run-test-ondotnet-lib] Error 1</div><div>make[1]: Leaving directory '/home/Antoine/<span class="" style="background-color:rgb(255,255,204)">mono</span>/mcs/class/System.ServiceModel.Web'</div><div>

../../build/rules.make:143: recipe for target 'do-run-test-ondotnet' failed</div><div>make: *** [do-run-test-ondotnet] Error 2</div></div><div style="font-family:arial,sans-serif;font-size:13px"><br></div><div style="font-family:arial,sans-serif;font-size:13px">

(I'm on cygwin, src based on trunk)<br><div><br></div><div>Any idea of how I could fix this?</div><div><br></div><div>Thanks,</div><div><br></div><div>Antoine</div></div></div>