<div dir="ltr">Hello,<div><br></div><div>To build Mono with a different prefix, you need to use a tarball package, that has all of the bits that are not typically checked into git.</div><div><br></div><div>That said, if you want to use git, you need to at least run this:</div>
<div><br></div><div>NOCONFIGURE=1 ./autogen.sh</div><div><br></div><div>On the directory where you did your checkout, and then you can run configure from a separate directory.</div></div><div class="gmail_extra"><br><br><div class="gmail_quote">
On Wed, May 21, 2014 at 3:32 PM, Chris Morgan <span dir="ltr"><<a href="mailto:chmorgan@gmail.com" target="_blank">chmorgan@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hello.<br>
<br>
I'm trying to build mono under Yocto. Recently (so I've heard) there<br>
were some changes such that the autotools scripts are being run from<br>
outside of the source tree.<br>
<br>
I presume this is something like:<br>
<br>
cd mono<br>
mkdir monobuild<br>
cd monobuild<br>
../autogen.sh<br>
<br>
<br>
[cmorgan@localhost monobuild]$ ../autogen.sh --prefix=/home/cmorgan/mono-prefix<br>
grep: <a href="http://configure.in" target="_blank">configure.in</a>: No such file or directory<br>
../autogen.sh: line 125: mono/mini/Makefile.am: No such file or directory<br>
../autogen.sh: line 126: mono/metadata/Makefile.am: No such file or directory<br>
Running aclocal -I m4 -I .  ...<br>
aclocal: error: '<a href="http://configure.ac" target="_blank">configure.ac</a>' is required<br>
<br>
**Error**: aclocal failed. This may mean that you have not<br>
installed all of the packages you need, or you may need to<br>
set ACLOCAL_FLAGS to include "-I $prefix/share/aclocal"<br>
for the prefix where you installed the packages whose<br>
macros were not found<br>
<br>
<br>
This doesn't appear to work because several things in autogen.sh<br>
assume that the files are present in the current working directory.<br>
Some other steps however do use $srcdir.<br>
<br>
My question is whether it seems like a reasonable idea to correct<br>
autogen.sh to remove the assumption that builddir == sourcedir. If so<br>
then I'll go down this route and send a patch. If not then I'll use a<br>
Yocto work around for projects that don't/can't support doing that.<br>
I'm not big on papering over issues so I do prefer the first option<br>
but I didn't want to start work if it turns out that it may be a<br>
nearly impossible task.<br>
<br>
Chris<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</blockquote></div><br></div>