<div dir="ltr"><div><div><div><div><div><div><div><br>Fantastic news!    Thanks for sharing that information, Sergey.<br><br></div>It sounds like the contract work for Tizen is going to be even more minimal, then, along the lines of ...<br>
<br></div>1. Make configure changes in an upstream-able, clean format.    Submit a pull request and get that accepted.  Tada!   We have Tizen support for Mono :-)<br></div>2. Verify that all appropriate samples and unit-tests are buildable and runnable against the Tizen emulator.    Make a list of WON'T FIX ones.<br>
</div>3. Work out how to augment the Mono automated builds/tests to include Tizen support.<br><br></div>On the question of automation ...  <a href="http://wrench.mono-project.com/builds">http://wrench.mono-project.com/builds</a> appears to be dead.<br>
<br></div>Is there automation for Mono separate from whatever Xamarin have running for their own needs?<br><br></div>For Tizen at least I would like to get automated builds and runs going within Windows Azure VMs which I will "sponsor" the costs of runnin.    Is there an existing automation infrastructure for this to be added to?   Thanks!<br>
<div><div><div><div><div><div><br><br>Cheers,<br>Bob<br></div></div></div></div></div></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Fri, Jun 13, 2014 at 8:36 AM, xplicit <span dir="ltr"><<a href="mailto:svg@ngs.ru" target="_blank">svg@ngs.ru</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I was able to compile and run mono on tizen(x86) out of the box. Only very<br>
small change is needed in <a href="http://configure.ac" target="_blank">configure.ac</a> to compile and run mono successfully.<br>
<br>
I even compiled my mono web-server HyperFastCgi v0.4<br>
(<a href="https://github.com/xplicit/HyperFastCgi" target="_blank">https://github.com/xplicit/HyperFastCgi</a>) and run it behind nginx on the<br>
Tizen machine with ServiceStack-hosted "hello, World!" web-application<br>
(front-end nginx is located on the Ubuntu machine and sends requests to<br>
tizen machine). Seems that all works fine, I've got "Hello, World!" message<br>
in my browser.<br>
<br>
Here are the the sequence of commands I had to do to compile mono<br>
<a href="https://gist.github.com/xplicit/2f8444afe162ac69a5f7" target="_blank">https://gist.github.com/xplicit/2f8444afe162ac69a5f7</a><br>
Here are the change for <a href="http://configure.ac" target="_blank">configure.ac</a><br>
<a href="https://gist.github.com/xplicit/f3d5d08b3eac836fae38" target="_blank">https://gist.github.com/xplicit/f3d5d08b3eac836fae38</a><br>
I use tizen_20140415.5_ivi-release-mbr-i586-sdb.raw image.<br>
<br>
<br>
<br>
--<br>
View this message in context: <a href="http://mono.1490590.n4.nabble.com/Still-seeking-contractor-to-adding-Tizen-support-to-Mono-tp4663022p4663077.html" target="_blank">http://mono.1490590.n4.nabble.com/Still-seeking-contractor-to-adding-Tizen-support-to-Mono-tp4663022p4663077.html</a><br>

Sent from the Mono - Dev mailing list archive at Nabble.com.<br>
<div class="HOEnZb"><div class="h5">_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</div></div></blockquote></div><br><br clear="all"><br>-- <br><a href="mailto:bob@summerwill.net">bob@summerwill.net</a><br><br>
</div>