<div dir="ltr">This is master off of the monodevelop, with 3.2.6 mono.<div><br></div><div>I can look into using a newer mono version, was using 3.2.6 as that is what we have as RPM's in our environment.</div></div><div class="gmail_extra">
<br><br><div class="gmail_quote">On Wed, Jul 9, 2014 at 3:02 PM, Timotheus Pokorra <span dir="ltr"><<a href="mailto:timotheus.pokorra@solidcharity.com" target="_blank">timotheus.pokorra@solidcharity.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hello Brandon,<br>
<br>
which version of Mono are you using?<br>
Version 3.4 should be fine.<br>
<span class="HOEnZb"><font color="#888888"><br>
Timotheus<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
On 9 July 2014 21:50, Brandon Perry <<a href="mailto:bperry.volatile@gmail.com">bperry.volatile@gmail.com</a>> wrote:<br>
> Indeed, installing latest git master resolves that issue.<br>
><br>
> [root@localhost monodevelop]# git --version<br>
> git version 2.0.0.GIT<br>
> [root@localhost monodevelop]#<br>
><br>
> 'make' still fails though, much later on in the build chain, researching it<br>
> now, but here is the error:<br>
><br>
> Errors:<br>
><br>
> /root/monodevelop/main/Main.sln (default targets) -><br>
> (Build target) -><br>
> /root/monodevelop/main/external/xwt/Xwt.Gtk/Xwt.Gtk.csproj (default targets)<br>
> -><br>
> /usr/local/lib/mono/4.0/Microsoft.CSharp.targets (CoreCompile target) -><br>
><br>
> Xwt.GtkBackend/CustomTreeModel.cs(88,12): error CS1501: No overload for<br>
> method `EmitRowsReordered' takes `3' arguments<br>
> Xwt.GtkBackend/CustomListModel.cs(62,12): error CS1501: No overload for<br>
> method `EmitRowsReordered' takes `3' arguments<br>
><br>
> 277 Warning(s)<br>
> 2 Error(s)<br>
><br>
> Time Elapsed 00:00:34.4877370<br>
> make[2]: *** [sln_build] Error 1<br>
> make[2]: Leaving directory `/root/monodevelop/main'<br>
> make[1]: *** [all-recursive] Error 1<br>
> make[1]: Leaving directory `/root/monodevelop/main'<br>
> make: *** [all-recursive] Error 1<br>
> [root@localhost monodevelop]#<br>
><br>
><br>
> Any thoughts are appreciated.<br>
><br>
><br>
> On Wed, Jul 9, 2014 at 2:34 PM, Brandon Perry <<a href="mailto:bperry.volatile@gmail.com">bperry.volatile@gmail.com</a>><br>
> wrote:<br>
>><br>
>> It does seem to be an issue with git 1.7.1. It does not seem to have a<br>
>> --count argument to 'git-rev-list'.<br>
>><br>
>> Going to upgrade git and try.<br>
>><br>
>><br>
>> On Wed, Jul 9, 2014 at 1:48 PM, Brandon Perry <<a href="mailto:bperry.volatile@gmail.com">bperry.volatile@gmail.com</a>><br>
>> wrote:<br>
>>><br>
>>> Thanks, this worked to pass the configuration.<br>
>>><br>
>>> However, make now fails:<br>
>>><br>
>>> [root@localhost monodevelop]# make<br>
>>> if test -d ".git"; then \<br>
>>> git submodule update --init --recursive || exit 1; \<br>
>>> fi<br>
>>> make[1]: Entering directory `/root/monodevelop/main'<br>
>>> Making all in external<br>
>>> make[2]: Entering directory `/root/monodevelop/main/external'<br>
>>> make[2]: Nothing to be done for `all'.<br>
>>> make[2]: Leaving directory `/root/monodevelop/main/external'<br>
>>> Making all in .<br>
>>> make[2]: Entering directory `/root/monodevelop/main'<br>
>>> if test -f "./buildinfo"; then cp "./buildinfo" "./build/bin/buildinfo";<br>
>>> else ./../scripts/configure.sh gen-buildinfo "./build/bin"; fi<br>
>>> /usr/bin/git failed<br>
>>> make[2]: *** [build/bin/buildinfo] Error 1<br>
>>> make[2]: Leaving directory `/root/monodevelop/main'<br>
>>> make[1]: *** [all-recursive] Error 1<br>
>>> make[1]: Leaving directory `/root/monodevelop/main'<br>
>>> make: *** [all-recursive] Error 1<br>
>>> [root@localhost monodevelop]#<br>
>>><br>
>>> I have git installed via yum:<br>
>>><br>
>>> [root@localhost monodevelop]# git --version<br>
>>> git version 1.7.1<br>
>>> [root@localhost monodevelop]#<br>
>>><br>
>>> Is a specific version of git required? All of my sources were checked out<br>
>>> with git, so I know it is at least functional.<br>
>>><br>
>>><br>
>>><br>
>>> On Wed, Jul 9, 2014 at 1:39 PM, Brandon Perry <<a href="mailto:bperry.volatile@gmail.com">bperry.volatile@gmail.com</a>><br>
>>> wrote:<br>
>>>><br>
>>>> Sure, I can definitely try this.<br>
>>>><br>
>>>><br>
>>>> On Wed, Jul 9, 2014 at 1:39 PM, Timotheus Pokorra<br>
>>>> <<a href="mailto:timotheus.pokorra@solidcharity.com">timotheus.pokorra@solidcharity.com</a>> wrote:<br>
>>>>><br>
>>>>> Hello Brandon,<br>
>>>>><br>
>>>>> > Running autoconf ...<br>
>>>>> > <a href="http://configure.in:1" target="_blank">configure.in:1</a>: error: possibly undefined macro: m4_esyscmd_s<br>
>>>>> >       If this token and others are legitimate, please use<br>
>>>>> > m4_pattern_allow.<br>
>>>>> >       See the Autoconf documentation.<br>
>>>>> > **Error**: autoconf failed.<br>
>>>>> The version of autoconf on CentOS6 is too old.<br>
>>>>> You can download the latest version from<br>
>>>>> <a href="http://ftp.gnu.org/gnu/autoconf/autoconf-2.69.tar.gz" target="_blank">http://ftp.gnu.org/gnu/autoconf/autoconf-2.69.tar.gz</a> and make install<br>
>>>>> it.<br>
>>>>><br>
>>>>> I think you also need the latest automake:<br>
>>>>> <a href="http://ftp.gnu.org/gnu/automake/automake-1.13.tar.gz" target="_blank">http://ftp.gnu.org/gnu/automake/automake-1.13.tar.gz</a><br>
>>>>> but I am not completely sure if that is required...<br>
>>>>><br>
>>>>> all the best,<br>
>>>>>   Timotheus<br>
>>>><br>
>>>><br>
>>>><br>
>>>><br>
>>>> --<br>
>>>> <a href="http://volatile-minds.blogspot.com" target="_blank">http://volatile-minds.blogspot.com</a> -- blog<br>
>>>> <a href="http://www.volatileminds.net" target="_blank">http://www.volatileminds.net</a> -- website<br>
>>><br>
>>><br>
>>><br>
>>><br>
>>> --<br>
>>> <a href="http://volatile-minds.blogspot.com" target="_blank">http://volatile-minds.blogspot.com</a> -- blog<br>
>>> <a href="http://www.volatileminds.net" target="_blank">http://www.volatileminds.net</a> -- website<br>
>><br>
>><br>
>><br>
>><br>
>> --<br>
>> <a href="http://volatile-minds.blogspot.com" target="_blank">http://volatile-minds.blogspot.com</a> -- blog<br>
>> <a href="http://www.volatileminds.net" target="_blank">http://www.volatileminds.net</a> -- website<br>
><br>
><br>
><br>
><br>
> --<br>
> <a href="http://volatile-minds.blogspot.com" target="_blank">http://volatile-minds.blogspot.com</a> -- blog<br>
> <a href="http://www.volatileminds.net" target="_blank">http://www.volatileminds.net</a> -- website<br>
</div></div></blockquote></div><br><br clear="all"><div><br></div>-- <br><a href="http://volatile-minds.blogspot.com">http://volatile-minds.blogspot.com</a> -- blog<br><a href="http://www.volatileminds.net">http://www.volatileminds.net</a> -- website
</div>