<div dir="ltr">I'm getting crazy :)<div><br></div><div>I removed my cloned source and get a new clone from git repo. nothing changed, again same problem.</div><div>I also tried to make the code in another pc - ubuntu 12.04  I got a new error:<br>
</div><div><br></div><div><div>make[2]: Entering directory `/home/morteza/git/mono/runtime'</div><div>if test -w /home/morteza/git/mono/mcs; then :; else chmod -R +w /home/morteza/git/mono/mcs; fi</div><div>cd /home/morteza/git/mono/mcs && make --no-print-directory -s NO_DIR_CHECK=1 PROFILES='net_2_0 net_3_5 net_4_0 net_4_5 xbuild_12   ' CC='gcc' all-profiles</div>
<div>Bootstrap compiler: Mono C# compiler version 2.10.8.1</div><div>MCS     [secxml/basic] System.dll</div><div>System.Security.AccessControl/SemaphoreSecurity.cs(136,35): warning CS0109: The member `System.Security.AccessControl.SemaphoreSecurity.PersistModifications(System.Runtime.InteropServices.SafeHandle)' does not hide an inherited member. The new keyword is not required</div>
<div>Mono.Http/NtlmClient.cs(99,54): error CS1502: The best overloaded method match for `Mono.Security.Protocol.Ntlm.Type3Message.Type3Message(byte[])' has some invalid arguments</div><div>/usr/lib/mono/gac/Mono.Security/2.0.0.0__0738eb9f132ed756/Mono.Security.dll (Location of the symbol related to previous error)</div>
<div>Mono.Http/NtlmClient.cs(99,54): error CS1503: Argument `#1' cannot convert `Mono.Security.Protocol.Ntlm.Type2Message' expression to type `byte[]'</div><div>Compilation failed: 2 error(s), 1 warnings</div>
<div>make[9]: *** [../../class/lib/basic/secxml/System.dll] Error 1</div><div>make[8]: *** [../../class/lib/basic/secxml/System.dll] Error 2</div><div>make[7]: *** [do-all] Error 2</div><div>make[6]: *** [all-recursive] Error 1</div>
<div>make[5]: *** [all-recursive] Error 1</div><div>make[4]: *** [profile-do--basic--all] Error 2</div><div>make[3]: *** [profiles-do--all] Error 2</div><div>make[2]: *** [all-local] Error 2</div><div>make[2]: Leaving directory `/home/morteza/git/mono/runtime'</div>
<div>make[1]: *** [all-recursive] Error 1</div><div>make[1]: Leaving directory `/home/morteza/git/mono'</div><div>make: *** [all] Error 2</div></div><div><br></div><div>I wonder how the same code gets built and installed in my virtual ubuntu machine!!</div>
<div><br></div></div><div class="gmail_extra"><br><br><div class="gmail_quote">On Wed, Jul 16, 2014 at 9:51 PM, Marek Safar <span dir="ltr"><<a href="mailto:marek.safar@gmail.com" target="_blank">marek.safar@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div class="gmail_extra"><div class="gmail_quote">Hello,</div><div class="gmail_quote"><div class=""><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">
No i didn't build in parallel. just a simple make command with no parameter.<div><br></div><div>when i ran the Make command for the first time i got an error said Perl XML:Parser wasn't installed.</div>
<div>so i installed XML::Parser by apt-get <span style="background-color:rgb(238,238,238);color:rgb(0,0,0);font-family:Consolas,Menlo,Monaco,'Lucida Console','Liberation Mono','DejaVu Sans Mono','Bitstream Vera Sans Mono','Courier New',monospace,serif;font-size:14px;line-height:17.804800033569336px;white-space:pre-wrap">libexpat1-dev</span></div>


<div><br></div><div>then  i ran into this error.</div></div></blockquote><div><br></div></div><div>That's probably it. Try to clean your code and rebuild again.</div><span class="HOEnZb"><font color="#888888"><div><br>
</div><div>Marek</div></font></span><div class=""><div><br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div><div><div class="gmail_extra"><div class="gmail_quote">On Wed, Jul 16, 2014 at 8:26 PM, Marek Safar <span dir="ltr"><<a href="mailto:marek.safar@gmail.com" target="_blank">marek.safar@gmail.com</a>></span> wrote:<br>


<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">Hello,<br><div class="gmail_extra"><div class="gmail_quote"><div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left-width:1px;border-left-color:rgb(204,204,204);border-left-style:solid;padding-left:1ex">



<div dir="ltr"><div><div><div><b><br></b></div><b>I successfully make & install the mono code in ubuntu 12.04<br></b></div><b>when i do the same steps in ubuntu 14.04 i get this error</b><br><br>Bootstrap compiler: Mono C# compiler version 3.2.8.0<br>




MCS     [build] System.Xml.dll<br>System.Xml.XPath/Parser.jay(12,0): error CS1525: Unexpected symbol `using'<br></div></div></blockquote><div><br></div></div><div>This is weird error. Did you try to build in parallel ? Also showing what is actually in file System.Xml.XPath/Parser.jay around reports lines would help too.</div>


<span><font color="#888888">
<div><br></div><div>Marek</div></font></span></div></div></div>
</blockquote></div><br></div>
</div></div></blockquote></div></div><br></div></div>
</blockquote></div><br></div>