<div dir="ltr"><div><div><div>$ export MONODEVELOP_SDB_TEST=1<br></div>$ monodevelop<br><br></div><div>Open the project you want to debug, Run->Run With...->Custom Command Soft Debugger,Listen<br><br><br>Then run mono on your remote machine with --debugger-agent=address=YOUR_HOST_WITH_MONODEVELOP:10000<br></div></div><div><br></div><br></div><div class="gmail_extra"><br><div class="gmail_quote">2014-09-10 9:22 GMT+04:00 Bryan Crotaz <span dir="ltr"><<a href="mailto:bryan.crotaz@silvercurve.co.uk" target="_blank">bryan.crotaz@silvercurve.co.uk</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I have exactly the same issue on raspberry Pi. SSL fails about 50% of<br>
the time. And I don't know how to do remote debug either.<br>
<span class="HOEnZb"><font color="#888888"><br>
Bryan Crotaz<br>
Silver Curve<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
> On 10 Sep 2014, at 03:45, Chris Tacke <<a href="mailto:ctacke@opennetcf.com">ctacke@opennetcf.com</a>> wrote:<br>
><br>
> I have a Mono project that mirrors a desktop project (same code, same projects, etc).  Most development and debugging is done in Visual Studio and the Linux/Mono deployment is done on the build server with a command-line call to compile the Mono build.<br>
><br>
> Generally speaking this all works just fine.<br>
><br>
> Occasionally, however, we find behavioral differences between the .NET Framework and Mono.  For example, right now I have code that works fine on the desktop, but under Mono it's failing (it's a socket call out to SSL, and yes, I've added a handler for ServicePointManager.ServerCertificateValidationCallback as a test but it still fails).<br>
><br>
> When I run into these types of problems, I use Xamarin Studio to add in Console.Writeline calls, build, copy via USB, reiterate cycles and try narrowing the problem down.  It's extremely slow and painful.<br>
><br>
> Xamarin Studio can connect and live debug against iOS and Android.  Is there a way to configure Xamarin Studio (or Visual Studio) and my Linux device to do the same?  I would suspect that someone out there has tried debugging against a Raspberry Pi or something and this would be an analogous situation.<br>
><br>
> If it matters, the Mono build I'm using is not off-the-shelf - I had to compile it myself since we're targeting the i586-cored Quark processors.<br>
><br>
> I used to have a license for both Xamarin iOS and Xamarin Android, but really we don't target those devices so I let them lapse.  I'm hoping that the debugging pieces aren't wrapped up in those.<br>
><br>
> -Chris<br>
><br>
> _______________________________________________<br>
> Mono-devel-list mailing list<br>
> <a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
> <a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</div></div></blockquote></div><br></div>