<div dir="ltr">A two-years's old mono (2.10, e are currently on 3.8) maybe didn't have a complete SerialPort implementation at that time. Please upgrade to a newer version. <div><br></div><div>Also MonoDevelop's metadata index for code completion may be out-of-sync with the installed Mono:</div><div>For older versions Michael Hutchinson answered in the archives for monodevelop-list:</div><div><br></div><div><span style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px">* Check the MD log for errors (~/.config/MonoDevelop/log) </span><br style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px"><span style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px">* Try cleaning out the pidb (complete data cache) files from your </span><span style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px">project directories </span><br style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px"><span style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px">* Try cleaning out the pidb files from ~/.config/MonoDevelop/CodeCompletionData </span><br style="color:rgb(0,0,0);font-family:Verdana,Geneva,Helvetica,Arial,sans-serif;font-size:17px"></div></div><div class="gmail_extra"><br clear="all"><div>Rafael Teixeira<br>O..:.)oooo<br></div>
<br><div class="gmail_quote">On Wed, Sep 24, 2014 at 10:28 PM, Daniel Piloco <span dir="ltr"><<a href="mailto:dpiloco@ditco.net" target="_blank">dpiloco@ditco.net</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hello Everyone,<br>
<br>
I'm new to mono/monodevelop and linux.  I have lots of experience with C# on windows however.<br>
<br>
Mono provides almost everything I need.  Except there's no assembly (or whatever its called) for System.IO.Ports.  Specifically, I'd like my program to be able to use the System.IO.Ports.SerialPort class.<br>
<br>
How can I use this class?<br>
<br>
Here's what I'm running:<br>
<br>
MonoDevelop 3.0.3.2<br>
Installation UUID: 71724472-0276-43db-8786-c4a8cda87fef<br>
Runtime:<br>
        Mono 2.10.8.1 (Debian 2.10.8.1-8) (64-bit)<br>
        GTK 2.24.10<br>
        GTK# (2.12.0.0)<br>
Build information:<br>
        Git revision: 7bf6ac0ca43c1b12703176ad9933c3484c05c84c-dirty<br>
        Build date: 2012-06-22 20:57:52+0000<br>
Operating System:<br>
        Linux<br>
        Linux VirtualHostDebian 3.2.0-4-amd64 #1 SMP Debian 3.2.57-3+deb7u1 x86_64 GNU/Linux<br>
<br>
Thank you,<br>
Daniel<br>
_______________________________________________<br>
Mono-devel-list mailing list<br>
<a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><br>
<a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br>
</blockquote></div><br></div>