<p dir="ltr">Hi all,</p>
<p dir="ltr">I'm going to try and dedicate a bit of time to the project over the next couple of months and need a little help understanding where to start with something specific.</p>
<p dir="ltr">I've been trying make an application mono compliant but came across a bug in that web Api 5.2.2 isn't compatible with mono.  I've seen a bug in the xamarin tracker around it, and Miguel has commented that it won't be compatible until we update mono's version of the aspnetwebstack.</p>
<p dir="ltr">Therefore, I'd like to look at that and try to fix anything that's needed as I go.</p>
<p dir="ltr">I've got no experience of using submodules in git, so any help on steps to pull in the latest code and build/test would be beneficial.  I've had a look at the guide on the mono site and it doesn't really make sense to me.</p>
<p dir="ltr">Further, I don't want to do this work if there is no chance of it being accepted.  The change will be large I assume, and I know there is a problem with getting large Pr's accepted.  If I was doing this for myself, I would simply amend the product I'm trying to get working, so I want to make sure it's not going to be in vain.</p>
<p dir="ltr">Also, has anyone looked into this in the past and knows of a reason why it won't work?</p>
<p dir="ltr">Thanks<br>
Martin</p>