<html>
  <head>
    <meta content="text/html; charset=windows-1256"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    Hi<br>
    <br>
    <div class="moz-cite-prefix">On 20141209 17:01 , Spyros
      Sakellariadis (MS OPEN TECH) wrote:<br>
    </div>
    <blockquote
cite="mid:CY1PR0301MB09054F49E7AB6115D0242FEBD5650@CY1PR0301MB0905.namprd03.prod.outlook.com"
      type="cite">
      <meta http-equiv="Content-Type" content="text/html;
        charset=windows-1256">
      <meta content="text/html; charset=iso-8859-1">
      <div>
        <div style="font-family:Calibri,sans-serif; font-size:11pt">Yes,
          to local<br>
        </div>
      </div>
    </blockquote>
    Great. Usually people do forget that one...<br>
    <br>
    Let me context switch to test.<br>
    <br>
    cheers<br>
    <br>
    Mel<br>
    <blockquote
cite="mid:CY1PR0301MB09054F49E7AB6115D0242FEBD5650@CY1PR0301MB0905.namprd03.prod.outlook.com"
      type="cite">
      <div>
        <div style="font-family:Calibri,sans-serif; font-size:11pt">
          <br>
          Sent from my Windows Phone</div>
      </div>
      <div dir="ltr">
        <hr>
        <span style="font-family:Calibri,sans-serif; font-size:11pt;
          font-weight:bold">From:
        </span><span style="font-family:Calibri,sans-serif;
          font-size:11pt"><a moz-do-not-send="true"
            href="mailto:mcvjetko@holisticware.net">Miljenko Cvjetko</a></span><br>
        <span style="font-family:Calibri,sans-serif; font-size:11pt;
          font-weight:bold">Sent:
        </span><span style="font-family:Calibri,sans-serif;
          font-size:11pt">ý12/ý9/ý2014 7:56 AM</span><br>
        <span style="font-family:Calibri,sans-serif; font-size:11pt;
          font-weight:bold">To:
        </span><span style="font-family:Calibri,sans-serif;
          font-size:11pt"><a moz-do-not-send="true"
            href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a></span><br>
        <span style="font-family:Calibri,sans-serif; font-size:11pt;
          font-weight:bold">Subject:
        </span><span style="font-family:Calibri,sans-serif;
          font-size:11pt">Re: [Mono-dev] Event logging under Mono</span><br>
        <br>
      </div>
      <div>Hi<br>
        <br>
        Did You set <span style="">MONO_EVENTLOG_TYPE?  
          win32|local|null;<br>
          <br>
          cheers<br>
          <br>
          mel<br>
          <br>
        </span>
        <div class="moz-cite-prefix">On 20141208 23:38 , Spyros
          Sakellariadis (MS OPEN TECH) wrote:<br>
        </div>
        <blockquote type="cite">
          <meta name="Generator" content="Microsoft Word 15 (filtered
            medium)">
          <style>
<!--
@font-face
        {font-family:"Cambria Math"}
@font-face
        {font-family:Calibri}
@font-face
        {font-family:Consolas}
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif}
a:link, span.MsoHyperlink
        {color:#0563C1;
        text-decoration:underline}
a:visited, span.MsoHyperlinkFollowed
        {color:#954F72;
        text-decoration:underline}
p.MsoListParagraph, li.MsoListParagraph, div.MsoListParagraph
        {margin-top:0in;
        margin-right:0in;
        margin-bottom:0in;
        margin-left:.5in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif}
span.EmailStyle17
        {font-family:"Calibri",sans-serif;
        color:windowtext}
.MsoChpDefault
        {font-family:"Calibri",sans-serif}
@page WordSection1
        {margin:1.0in 1.0in 1.0in 1.0in}
div.WordSection1
        {}
ol
        {margin-bottom:0in}
ul
        {margin-bottom:0in}
-->
</style>
          <div class="WordSection1">
            <p class="MsoNormal">[Sorry if duplicate. I think I
              originally sent to wrong alias]</p>
            <p class="MsoNormal"> </p>
            <p class="MsoNormal"><span style="color:#1F497D">Hi –</span></p>
            <p class="MsoNormal"><span style="color:#1F497D"> </span></p>
            <p class="MsoNormal"><span style="color:#1F497D">I am trying
                to implement logging for a small application running
                under Mono on a Raspberry Pi. Unfortunately I have been
                unable to create an event log despite following guidance
                that I have found on the Net, and am wondering if there
                is best practice on how to do this. FWIW, the steps I
                have taken are as follows:</span></p>
            <p class="MsoNormal"><span style="color:#1F497D"> </span></p>
            <p class="MsoListParagraph" style="text-indent:-.25in"><span
                style="color:#1F497D"><span style="">1.<span
                    style="font:7.0pt "Times New Roman"">      
                  </span></span></span><span style="color:#1F497D">On
                the Raspberry Pi, I created /var/lib/mono and
                /var/lib/mono/eventlog directories, set directory
                permission on each to 777 per
              </span><a moz-do-not-send="true"
href="http://lists.ximian.com/pipermail/mono-devel-list/2006-August/019853.html">http://lists.ximian.com/pipermail/mono-devel-list/2006-August/019853.html</a><span
                style="color:#1F497D">.
              </span></p>
            <p class="MsoListParagraph" style="text-indent:-.25in"><span
                style="color:#1F497D"><span style="">2.<span
                    style="font:7.0pt "Times New Roman"">      
                  </span></span></span><span style="color:#1F497D">Ran
                the following .NET code, based loosely on
              </span><a moz-do-not-send="true"
href="http://msdn.microsoft.com/en-us/library/system.diagnostics.eventlog%28v=vs.110%29.aspx"><span
                  style="font-size:9.5pt; font-family:Consolas;
                  background:white">http://msdn.microsoft.com/en-us/library/system.diagnostics.eventlog(v=vs.110).aspx</span></a><span
                style="font-size:9.5pt; font-family:Consolas;
                color:#1F497D">:</span><span style="font-size:9.5pt;
                font-family:Consolas; color:green">
              </span><span style="color:#1F497D"></span></p>
            <p class="MsoNormal"><span style="color:#1F497D"> </span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">using System;</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">using System.Text;</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">using System.Diagnostics;
              </span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">namespace Logging</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">{</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">    class Program</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">    {</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">        static void Main(string[]
                args)</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">        {</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">            if
                (!EventLog.SourceExists("MySource"))</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">            {</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">               
                EventLog.CreateEventSource("MySource", "MyNewLog");</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">               
                Console.WriteLine("CreatedEventSource");</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">             
                  Console.WriteLine("Exiting, execute the application a
                second time to use the source.");</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">                return;</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">            }</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">            else</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">               
                Console.WriteLine("Found the EventLog Source.");</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">            return;</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">        }</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">    }</span></p>
            <p class="MsoNormal" style="margin-left:.5in"><span
                style="color:#1F497D">}</span></p>
            <p class="MsoNormal"><span style="color:#1F497D"> </span></p>
            <p class="MsoNormal"><span style="color:#1F497D">If I run
                this twice on a Windows 8 machine, the first time it
                comes back with “CreatedEventSource”, the second time it
                comes back with “Found the EventLog Source”, and the
                Windows Event Log has a new log entitled MyNewLog.
                However, if I run it on the Raspberry Pi under mono, I
                get the message “CreatedEventSource” no matter how many
                times I run it, and no files are created in
                /var/lib/mono/eventlog.</span></p>
            <p class="MsoNormal"><span style="color:#1F497D"> </span></p>
            <p class="MsoNormal"><span style="color:#1F497D">What am I
                missing, or what should I try instead?</span></p>
            <p class="MsoNormal"><span style="color:#1F497D"> </span></p>
            <p class="MsoNormal"><span style="color:#1F497D">Spyros
                Sakellariadis</span></p>
            <p class="MsoNormal"><span style="color:#1F497D">Microsoft
                Open Technologies, Inc.</span></p>
            <p class="MsoNormal"><a moz-do-not-send="true"
                href="mailto:spyros@microsoft.com">spyros@microsoft.com</a><span
                style="color:#1F497D"></span></p>
            <p class="MsoNormal"> </p>
            <p class="MsoNormal"> </p>
          </div>
          <br>
          <fieldset class="mimeAttachmentHeader"></fieldset>
          <br>
          <pre>_______________________________________________
Mono-devel-list mailing list
<a moz-do-not-send="true" class="moz-txt-link-abbreviated" href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a>
<a moz-do-not-send="true" class="moz-txt-link-freetext" href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a>
</pre>
        </blockquote>
        <br>
      </div>
    </blockquote>
    <br>
  </body>
</html>