<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1255">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<!--[if !mso]><style>v\:* {behavior:url(#default#VML);}
o\:* {behavior:url(#default#VML);}
w\:* {behavior:url(#default#VML);}
.shape {behavior:url(#default#VML);}
</style><![endif]--><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
@font-face
        {font-family:Menlo;
        panose-1:0 0 0 0 0 0 0 0 0 0;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        color:black;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
pre
        {mso-style-priority:99;
        mso-style-link:"HTML Preformatted Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:10.0pt;
        font-family:"Courier New";
        color:black;}
p.MsoListParagraph, li.MsoListParagraph, div.MsoListParagraph
        {mso-style-priority:34;
        margin-top:0in;
        margin-right:0in;
        margin-bottom:0in;
        margin-left:.5in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;
        color:black;}
p.msochpdefault, li.msochpdefault, div.msochpdefault
        {mso-style-name:msochpdefault;
        mso-margin-top-alt:auto;
        margin-right:0in;
        mso-margin-bottom-alt:auto;
        margin-left:0in;
        font-size:12.0pt;
        font-family:"Calibri",sans-serif;
        color:black;}
span.emailstyle17
        {mso-style-name:emailstyle17;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
span.HTMLPreformattedChar
        {mso-style-name:"HTML Preformatted Char";
        mso-style-priority:99;
        mso-style-link:"HTML Preformatted";
        font-family:Consolas;
        color:black;}
span.EmailStyle22
        {mso-style-type:personal-reply;
        font-family:"Calibri",sans-serif;
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body bgcolor="white" lang="EN-US" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal"><a name="_MailEndCompose"><span style="color:#1F497D">Adding the SetEnvironmenVariable in Main worked – thanks!<o:p></o:p></span></a></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D">FYI – another suggestion on the mailing list was to use NLog. Implemented that as well, and that worked like a charm too.
<o:p></o:p></span></p>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<div>
<p class="MsoNormal"><span style="font-size:12.0pt;color:#1F497D">Spyros Sakellariadis<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt;color:#1F497D">MS Open Technologies, Inc.<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:9.0pt;color:#1F497D">Office </span><a href="callto:+14257077623"><span style="font-size:9.0pt;color:#0563C1">+1(425) 707-7623</span></a><span style="font-size:9.0pt;color:#1F497D">   -  Mobile
</span><a href="callto:+14254441884"><span style="font-size:9.0pt;color:#0563C1">+1(425) 444-1884</span></a><span style="font-size:9.0pt;color:#1F497D"><o:p></o:p></span></p>
</div>
<p class="MsoNormal"><span style="color:#1F497D"><o:p> </o:p></span></p>
<div>
<div style="border:none;border-top:solid #E1E1E1 1.0pt;padding:3.0pt 0in 0in 0in">
<p class="MsoNormal"><b><span style="color:windowtext">From:</span></b><span style="color:windowtext"> Miljenko Cvjetko [mailto:mcvjetko@holisticware.net]
<br>
<b>Sent:</b> Tuesday, December 9, 2014 8:21 AM<br>
<b>To:</b> Spyros Sakellariadis (MS OPEN TECH); mono-devel-list@lists.ximian.com<br>
<b>Subject:</b> Re: [Mono-dev] Event logging under Mono<o:p></o:p></span></p>
</div>
</div>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal" style="margin-bottom:12.0pt">Hey<br>
<br>
this is probably shell variable problem. Did you export it?<br>
<br>
I had the same behavior (testing on my Mac). I did not create /var/lib/mono, so I would get exception.<br>
Added following line at the begining of the Main<br>
<br>
<span style="font-family:"Menlo",serif;color:#333333">            </span><span style="font-family:"Menlo",serif;color:#3364A4">Environment</span><span style="font-family:"Menlo",serif;color:#333333">.SetEnvironmentVariable( </span><span style="font-family:"Menlo",serif;color:#F57D00">"MONO_EVENTLOG_TYPE"</span><span style="font-family:"Menlo",serif;color:#333333">, </span><span style="font-family:"Menlo",serif;color:#F57D00">"local"</span><span style="font-family:"Menlo",serif;color:#333333">);</span><span style="font-family:"Menlo",serif"><br>
</span>This way I'm sure variable is in the same shell instance.<br>
<br>
after that I got:<br>
<br>
    Access to the path "/var/lib/mono" is denied.<br>
<br>
So I assume right now it is trying to write to /var/lib/mono/SOMETING. <br>
Stopping here....<br>
<br>
So your app did not "pick up" envirnonment variable. <br>
<br>
hope this helps<br>
<br>
Mel<span style="font-size:12.0pt"><o:p></o:p></span></p>
<div>
<p class="MsoNormal">On 20141209 17:01 , Spyros Sakellariadis (MS OPEN TECH) wrote:<o:p></o:p></p>
</div>
<blockquote style="margin-top:5.0pt;margin-bottom:5.0pt">
<div>
<div>
<p class="MsoNormal">Yes, to local<br>
<br>
Sent from my Windows Phone<o:p></o:p></p>
</div>
</div>
<div>
<div class="MsoNormal" align="center" style="text-align:center">
<hr size="2" width="100%" align="center">
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><b>From: </b><a href="mailto:mcvjetko@holisticware.net">Miljenko Cvjetko</a><br>
<b>Sent: </b>ý12/ý9/ý2014 7:56 AM<br>
<b>To: </b><a href="mailto:mono-devel-list@lists.ximian.com">mono-devel-list@lists.ximian.com</a><br>
<b>Subject: </b>Re: [Mono-dev] Event logging under Mono<o:p></o:p></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt">Hi<br>
<br>
Did You set MONO_EVENTLOG_TYPE?   win32|local|null;<br>
<br>
cheers<br>
<br>
mel<o:p></o:p></p>
<div>
<p class="MsoNormal">On 20141208 23:38 , Spyros Sakellariadis (MS OPEN TECH) wrote:<o:p></o:p></p>
</div>
<blockquote style="margin-top:5.0pt;margin-bottom:5.0pt">
<div>
<p class="MsoNormal">[Sorry if duplicate. I think I originally sent to wrong alias]<o:p></o:p></p>
<p class="MsoNormal"> <o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D">Hi –</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D">I am trying to implement logging for a small application running under Mono on a Raspberry Pi. Unfortunately I have been unable to create an event log despite following guidance that I have found on the Net,
 and am wondering if there is best practice on how to do this. FWIW, the steps I have taken are as follows:</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-.25in"><span style="color:#1F497D">1.</span><span style="font-size:7.0pt;font-family:"Times New Roman",serif;color:#1F497D">      
</span><span style="color:#1F497D">On the Raspberry Pi, I created /var/lib/mono and /var/lib/mono/eventlog directories, set directory permission on each to 777 per
</span><a href="http://lists.ximian.com/pipermail/mono-devel-list/2006-August/019853.html">http://lists.ximian.com/pipermail/mono-devel-list/2006-August/019853.html</a><span style="color:#1F497D">.
</span><o:p></o:p></p>
<p class="MsoListParagraph" style="text-indent:-.25in"><span style="color:#1F497D">2.</span><span style="font-size:7.0pt;font-family:"Times New Roman",serif;color:#1F497D">      
</span><span style="color:#1F497D">Ran the following .NET code, based loosely on </span>
<a href="http://msdn.microsoft.com/en-us/library/system.diagnostics.eventlog%28v=vs.110%29.aspx"><span style="font-size:9.5pt;font-family:Consolas;background:white">http://msdn.microsoft.com/en-us/library/system.diagnostics.eventlog(v=vs.110).aspx</span></a><span style="font-size:9.5pt;font-family:Consolas;color:#1F497D">:</span><span style="font-size:9.5pt;font-family:Consolas;color:green">
</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">using System;</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">using System.Text;</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">using System.Diagnostics;
</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">namespace Logging</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">{</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">    class Program</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">    {</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">        static void Main(string[] args)</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">        {</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">            if (!EventLog.SourceExists("MySource"))</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">            {</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">                EventLog.CreateEventSource("MySource", "MyNewLog");</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">                Console.WriteLine("CreatedEventSource");</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">                Console.WriteLine("Exiting, execute the application a second time to use the source.");</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">                return;</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">            }</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">            else</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">                Console.WriteLine("Found the EventLog Source.");</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">            return;</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">        }</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">    }</span><o:p></o:p></p>
<p class="MsoNormal" style="margin-left:.5in"><span style="color:#1F497D">}</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D">If I run this twice on a Windows 8 machine, the first time it comes back with “CreatedEventSource”, the second time it comes back with “Found the EventLog Source”, and the Windows Event Log has a new log entitled
 MyNewLog. However, if I run it on the Raspberry Pi under mono, I get the message “CreatedEventSource” no matter how many times I run it, and no files are created in /var/lib/mono/eventlog.</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D">What am I missing, or what should I try instead?</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D"> </span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D">Spyros Sakellariadis</span><o:p></o:p></p>
<p class="MsoNormal"><span style="color:#1F497D">Microsoft Open Technologies, Inc.</span><o:p></o:p></p>
<p class="MsoNormal"><a href="mailto:spyros@microsoft.com">spyros@microsoft.com</a><o:p></o:p></p>
<p class="MsoNormal"> <o:p></o:p></p>
<p class="MsoNormal"> <o:p></o:p></p>
</div>
<p class="MsoNormal"><span style="font-size:12.0pt;font-family:"Times New Roman",serif"><br>
<br>
<o:p></o:p></span></p>
<pre>_______________________________________________<o:p></o:p></pre>
<pre>Mono-devel-list mailing list<o:p></o:p></pre>
<pre><a href="mailto:Mono-devel-list@lists.ximian.com">Mono-devel-list@lists.ximian.com</a><o:p></o:p></pre>
<pre><a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><o:p></o:p></pre>
</blockquote>
<p class="MsoNormal"><span style="font-size:12.0pt;font-family:"Times New Roman",serif"><o:p> </o:p></span></p>
</div>
</blockquote>
<p class="MsoNormal"><span style="font-size:12.0pt;font-family:"Times New Roman",serif"><o:p> </o:p></span></p>
</div>
</body>
</html>