<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri",sans-serif;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">My first post…so here goes.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I am attempting to port a large enterprise application to mono, and have been pleasantly surprised at how well most things work.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I am hitting one snag executing a SqlCommand that includes a SqlParameter whose data type is SqlDbType.TinyInt (have also tried Int), and whose value is DBNull.Value.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I just installed the latest monodevelop last Friday (v5.7).  Any fix or workaround would be appreciated!<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">:::Repro C# code:<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">      private static void SqlTest()<o:p></o:p></p>
<p class="MsoNormal">      {<o:p></o:p></p>
<p class="MsoNormal">         using ( var con = new SqlConnection( "Application Name=MyApp;Data Source=machinename;Database=MGLatest_Mono;User ID=sa;Pwd=xxx;MultipleActiveResultSets=True" ) )<o:p></o:p></p>
<p class="MsoNormal">         {<o:p></o:p></p>
<p class="MsoNormal">            con.Open();<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">            using ( var cmd = con.CreateCommand() )<o:p></o:p></p>
<p class="MsoNormal">            {<o:p></o:p></p>
<p class="MsoNormal">               cmd.CommandType = System.Data.CommandType.StoredProcedure;<o:p></o:p></p>
<p class="MsoNormal">               cmd.CommandText = "DoTest";<o:p></o:p></p>
<p class="MsoNormal">               cmd.Parameters.Add( new SqlParameter( "@byte", System.Data.SqlDbType.TinyInt ) );<o:p></o:p></p>
<p class="MsoNormal">               cmd.Parameters[ "@byte" ].Direction = System.Data.ParameterDirection.Output;<o:p></o:p></p>
<p class="MsoNormal">               // cmd.Parameters[ "@byte" ].Value = (byte)0;  // THIS WORKS<o:p></o:p></p>
<p class="MsoNormal">               cmd.Parameters[ "@byte" ].Value = DBNull.Value;  // THIS FAILS (as does null, or omitting)<o:p></o:p></p>
<p class="MsoNormal">               cmd.ExecuteNonQuery();<o:p></o:p></p>
<p class="MsoNormal">               Console.WriteLine( cmd.Parameters[ "@byte" ].Value );<o:p></o:p></p>
<p class="MsoNormal">            }<o:p></o:p></p>
<p class="MsoNormal">         }<o:p></o:p></p>
<p class="MsoNormal">      }<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">:::Repro Store Proc:<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.5pt;font-family:Consolas;color:blue">create</span><span style="font-size:9.5pt;font-family:Consolas">
<span style="color:blue">proc</span> <span style="color:teal">DoTest</span><span style="color:gray">(</span><span style="color:teal">@byte</span>
<span style="color:blue">tinyint</span> <span style="color:blue">output</span><span style="color:gray">)</span><o:p></o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.5pt;font-family:Consolas;color:blue">as</span><span style="font-size:9.5pt;font-family:Consolas"><o:p></o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.5pt;font-family:Consolas;color:blue">set</span><span style="font-size:9.5pt;font-family:Consolas">
<span style="color:teal">@byte</span> <span style="color:gray">=</span> 238<o:p></o:p></span></p>
<p class="MsoNormal" style="text-autospace:none"><span style="font-size:9.5pt;font-family:Consolas"><o:p> </o:p></span></p>
<p class="MsoNormal">:::Exception:<o:p></o:p></p>
<p class="MsoNormal">Unhandled Exception:<o:p></o:p></p>
<p class="MsoNormal">System.Data.SqlClient.SqlException: The incoming tabular data stream (TDS) remote procedure call (RPC) protocol stream is incorrect. Parameter 1 ("@byte"): Data type 0x26 has an invalid data length or metadata length.<o:p></o:p></p>
</div>
</body>
</html>