<html>
<head>
<style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style></head>
<body class='hmmessage'><div dir='ltr'><font color="#000000" face="Calibri,sans-serif">You can try "make install V=1" for more output as well. <br id="FontBreak"></font><br> <BR><div><hr id="stopSpelling">From: chaselton@gmail.com<br>Date: Sun, 31 May 2015 11:49:26 -0500<br>To: sushihangover@outlook.com; mono-devel-list@lists.ximian.com<br>Subject: Re: [Mono-dev] mono make install fails with Error 1<br><br>If I didn't lose you at "no sudo, Android" here's the output from make --debug=vv install:<br>
<br>
Invoking recipe from ../../build/library.make:197 to update target `install-local'.<br>
make[1]: Entering directory `/bld/mono/mono-4.0.0/mcs/class/System'<br>
MONO_PATH="./../../class/lib/build:$MONO_PATH" /bld/mono/mono-4.0.0/runtime/mono-wrapper  ./../../class/lib/build/gacutil.exe /i ./../../class/lib/net_4_5/System.dll /f /gacdir /usr/mono/lib /root /usr/mono/lib /package 4.5<br>
make[1]: *** [install-local] Error 1<br>
make[1]: Leaving directory `/bld/mono/mono-4.0.0/mcs/class/System'<br>
make: *** [do-install] Error 2<br><br><div class="ecxgmail_quote">On May 31, 2015 11:30:51 AM CDT, Robert N <sushihangover@outlook.com> wrote:<blockquote class="ecxgmail_quote" style="padding-left: 1ex; border-left-color: rgb(204, 204, 204); border-left-width: 1px; border-left-style: solid;">
<pre class="ecxk9mail">did you try it with sudo?<br><br>cd into the mcs/class/System and do a 'gacutil -i System.dll' to see if that is really working.<br><br>and check the results via : gacutil -l <br><br>Also run make in verbose debug mode and see which step is failing.<br><br><hr><br><blockquote class="ecxgmail_quote" style="padding-left: 1ex; border-left-color: rgb(114, 159, 207); border-left-width: 1px; border-left-style: solid;"> Subject: RE: [Mono-dev] mono make install fails with Error 1 <br> From: chaselton@gmail.com <br> Date: Sun, 31 May 2015 11:15:00 -0500 <br> To: mono-devel-list@lists.ximian.com <br> CC: sushihangover@outlook.com <br> <br> This is going to sound weird, but I think the error is being thrown <br> after the update but before the successful install message. <br> <br> Here's the listing of lib/mono/gac and subdirs after running make <br> install in <sourcebasedir>/mcs/class/System: <br> <br> /bld/mono/mono-4.0.0 $ ls -al
/usr/mono/lib/mono/gac <br> total 12 <br> drwxrwx--- 3 u0_a186 u0_a186 4096 May 31 10:27 . <br> drwxrwx--- 8 u0_a186 u0_a186 4096 May 31 10:27 .. <br> drwxrwx--- 3 u0_a186 u0_a186 4096 May 31 11:06 System <br> /bld/mono/mono-4.0.0 $ ls -al /usr/mono/lib/mono/gac/System/ <br> total 12 <br> drwxrwx--- 3 u0_a186 u0_a186 4096 May 31 11:06 . <br> drwxrwx--- 3 u0_a186 u0_a186 4096 May 31 10:27 .. <br> drwxrwx--- 2 u0_a186 u0_a186 4096 May 31 11:06 4.0.0.0__b77a5c561934e089 <br> /bld/mono/mono-4.0.0 $ ls -al <br> /usr/mono/lib/mono/gac/System/4.0.0.0__b77a5c561934e089/ <br> total 2856 <br> drwxrwx--- 2 u0_a186 u0_a186 4096 May 31 11:06 . <br> drwxrwx--- 3 u0_a186 u0_a186 4096 May 31 11:06 .. <br> -rwxrwx--- 1 u0_a186 u0_a186 2063360 May 30 06:12 System.dll <br> -rw-rwx--- 1 u0_a186 u0_a186 851131 May 30 06:12 System.dll.mdb <br> <br> But make install still fails <br> <br> <br> <br> On May 31, 2015 10:53:09 AM CDT, Robert N
<sushihangover@outlook.com> wrote: <br> <br> Permissions problem? Looks like you are installing into /usr/mono/lib (FYI: I'd be careful, installing builds into system usr is not a good idea usually). <br> <br> At that point of the install it is trying to update the gac with System.dll so I would assume you do not have permissions, you can always do a 'sudo make install'. <br> <br> If you cd into <sourcebasedir>/mcs/class/System and do a sudo make install you should see the successful gac update like this: <br> <br> Installed ./../../class/lib/net_4_5/System.dll into the gac (/Users/administrator/playscript-install/lib/mono/gac) <br> <br> <br><hr><br> <br> From: chaselton@gmail.com <br> Date: Sun, 31 May 2015 09:29:20 -0500 <br> To: mono-devel-list@lists.ximian.com <br> Subject: [Mono-dev] mono make install fails with Error 1 <br> <br> I've finally managed to get mono to <br> build from sources, but make <br> install invoked from
the top build directory fails at the following <br> point: <br> <br> make[6]: Entering directory `/bld/mono/mono-4.0.0/mcs/class/System' <br> make install-local <br> WARNING: generic atexit() called from legacy shared library <br> make[7]: Entering directory `/bld/mono/mono-4.0.0/mcs/class/System' <br> MONO_PATH="./../../class/lib/build:$MONO_PATH" <br> /bld/mono/mono-4.0.0/runtime/mono-wrapper <br> ./../../class/lib/build/gacutil.exe /i <br> ./../../class/lib/net_4_5/System.dll /f /root /usr/mono/lib /package <br> 4.5 <br> make[7]: *** [install-local] Error 1 <br> make[7]: Leaving directory `/bld/mono/mono-4.0.0/mcs/class/System' <br> make[6]: *** [do-install] Error 2 <br> <br> Error 1 is the only error thrown. <br> <br> I can run this command without errors <br> <br> MONO_PATH="./../../class/lib/build:$MONO_PATH" <br> /bld/mono/mono-4.0.0/runtime/mono-wrapper <br> <br> ./../../class/lib/build/gacutil.exe /i <br>
./../../class/lib/net_4_5/System.dll /f /root /usr/mono/lib /package <br> 4.5 <br> <br> And I can run the final command in mono-wrapper without errors <br> <br> /bld/mono/mono-4.0.0 $ /bld/mono/mono-4.0.0/libtool --verbose <br> --mode=execute "mono/mini/mono" --config <br> "/bld/mono/mono-4.0.0/runtime/etc/mono/config" <br> "mcs/class/lib/build/gacutil.exe" /i mcs/class/lib/net_4_5/System.dll <br> /f /root /usr/mono/lib /package 4.5 <br> <br> But running 'make install' fails. Any ideas? <br><hr><br> Mono-devel-list mailing <br> list Mono-devel-list@lists.ximian.com <br> <a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a> <br> <br> <br> -- <br> Sent from my Android device with K-9 Mail. Please excuse my brevity. <br></blockquote>            </pre></blockquote></div><br>
-- <br>
Sent from my Android device with K-9 Mail. Please excuse my brevity.<br>_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.ximian.com
http://lists.ximian.com/mailman/listinfo/mono-devel-list</div>                                      </div></body>
</html>