<html><head><style><!--
.hmmessage P
{
margin:0px;
padding:0px
}
body.hmmessage
{
font-size: 12pt;
font-family:Calibri
}
--></style><style><!--
.ExternalClass .ecxhmmessage P {
padding:0px;
}

.ExternalClass body.ecxhmmessage {
font-size:12pt;
font-family:Calibri;
}

--></style></head><body class="hmmessage">Unfortunately the latest build...with ncurses this time...didn't change anything.  Same output for xbuild.<br>
<br>
Alexander, could you send the code for the Project.exe you sent me?<br><br><div class="gmail_quote">On June 5, 2015 3:25:42 AM CDT, "Alexander Köplinger" <alex.koeplinger@outlook.com> wrote:<blockquote class="gmail_quote" style="margin: 0pt 0pt 0pt 0.8ex; border-left: 1px solid rgb(204, 204, 204); padding-left: 1ex;">



<div dir="ltr"><font color="#000000" face="Calibri,sans-serif">Can you try this simple Hello World exe to confirm basic Mono is working and it's something specific to xbuild: <a href="https://dl.dropboxusercontent.com/u/21102229/Program.zip">https://dl.dropboxusercontent.com/u/21102229/Program.zip</a> (it just prints the current date).</font><br /> <br />I believe there's some terminal requirements, but not sure. Redirecting output to a file might work.<br /> <br /><div><hr id="stopSpelling" />From: chaselton@gmail.com<br />Date: Thu, 4 Jun 2015 19:56:01 -0500<br />To: sushihangover@outlook.com; mono-devel-list@lists.ximian.com<br />Subject: Re: [Mono-dev] mono 4.0.0 xbuild won't build project<br /><br />I tried it just now and I get the same result as before, unfortunately.<br />
<br />
Is there a terminfo/ncurses requirement for xbuild?  Or for mono in general? The rebuild I mentioned earlier was done in order to make sure -lncurses and all related headers and libs were included but it's possible I left something out and need to re-build again.<br />
<br />
Additionally, is there a terminal tyoe requirement for xbuild?  The android environment i'm using only comes with two types but I;ve got a working tic and sources so I can always install more.<br /><br /><div class="ecxgmail_quote">On June 4, 2015 6:51:00 PM CDT, Robert N <sushihangover@outlook.com> wrote:<blockquote class="ecxgmail_quote" style="padding-left: 1ex; border-left-color: rgb(204, 204, 204); border-left-width: 1px; border-left-style: solid;">



<div dir="ltr">I realized that my other mail was hosed, outlook in a browser does blow at times...<div><br /></div><div>So I was wondering if you were able to run xbuild using the mono option -v, since <span style="font-size: 12pt;">xbuild /verbosity:diagnostic</span><font size="3"> never spills even the first line of the </font>diag<font size="3"> text: </font><span style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Loading default tasks for ToolsVersion</span></div><div><br /></div><div>Using mono_options -v 'should' dump about 6500 lines before even getting to the version/copyright notice... assuming something in there is causing a silent fault(?) and exit.</div><div><br /></div><div><p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Win81Pro:Pash administrator$ MONO_OPTIONS="-v" xbuild Pash.proj |more</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method System.OutOfMemoryException:.ctor (string)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method System.OutOfMemoryException:.ctor (string) emitted at 0x4f7d20 to 0x4f7d44 (code length 36) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method (wrapper runtime-invoke) <Module>:runtime_invoke_void__this___object (object,intptr,intptr,intptr)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method (wrapper runtime-invoke) <Module>:runtime_invoke_void__this___object (object,intptr,intptr,intptr) emitted at 0x4f7d60 to 0x4f7e38 (code length 216) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method System.SystemException:.ctor (string)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method System.SystemException:.ctor (string) emitted at 0x4f7e38 to 0x4f7e5c (code length 36) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method System.Exception:.ctor (string)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method System.Exception:.ctor (string) emitted at 0x4f7e68 to 0x4f7ea1 (code length 57) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method System.NullReferenceException:.ctor (string)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method System.NullReferenceException:.ctor (string) emitted at 0x4f7ea8 to 0x4f7ecc (code length 36) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method System.StackOverflowException:.ctor (string)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method System.StackOverflowException:.ctor (string) emitted at 0x4f7ed0 to 0x4f7eea (code length 26) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method Mono.XBuild.CommandLine.MainClass:Main (string[])</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method Mono.XBuild.CommandLine.MainClass:Main (string[]) emitted at 0x4f7ef0 to 0x4f7f52 (code length 98) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method (wrapper runtime-invoke) <Module>:runtime_invoke_void_object (object,intptr,intptr,intptr)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method (wrapper runtime-invoke) <Module>:runtime_invoke_void_object (object,intptr,intptr,intptr) emitted at 0x4f7f78 to 0x4f8044 (code length 204) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method (wrapper alloc) object:AllocSmall (intptr,intptr)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method (wrapper alloc) object:AllocSmall (intptr,intptr) emitted at 0x4f8050 to 0x4f80b6 (code length 102) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method Mono.XBuild.CommandLine.MainClass:.ctor ()</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method Mono.XBuild.CommandLine.MainClass:.ctor () emitted at 0x4f80b8 to 0x4f8152 (code length 154) [xbuild.exe]</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">converting method Microsoft.Build.Utilities.ToolLocationHelper:GetPathToDotNetFramework (Microsoft.Build.Utilities.TargetDotNetFrameworkVersion)</p>
<p style="color: rgb(41, 249, 20); font-family: "Andale Mono"; font-size: 12px; background-color: rgb(0, 0, 0);">Method Microsoft.Build.Utilities.ToolLocationHelper:GetPathToDotNetFramework (Microsoft.Build.Utilities.TargetDotNetFrameworkVersion) emitted at 0x4f8178 to 0x4f81aa (code length 50) [xbuild.exe]</p><div><br /></div><br /><div><hr id="ecxstopSpelling" />From: chaselton@gmail.com<br />Date: Thu, 4 Jun 2015 17:00:01 -0500<br />To: atsushieno@veritas-vos-liberabit.com; alan.mcgovern@gmail.com<br />CC: mono-devel-list@lists.ximian.com<br />Subject: Re: [Mono-dev] mono 4.0.0 xbuild won't build project<br /><br />Here you go...<br />
<br />
/bld/pash/Pash-Project-Pash-bc07215 $ xbuild /verbosity:diagnostic hello.proj<br />
XBuild Engine Version 12.0<br />
Mono, Version <a href="http://4.0.0.0" target="_blank">4.0.0.0</a><br />
Copyright (C) 2005-2013 Various Mono authors<br />
/bld/pash/Pash-Project-Pash-bc07215 $<br /><br /><div class="ecxgmail_quote">On June 4, 2015 1:14:33 PM CDT, Atsushi Eno <atsushieno@veritas-vos-liberabit.com> wrote:<blockquote class="ecxgmail_quote" style="padding-left: 1ex; border-left-color: rgb(204, 204, 204); border-left-width: 1px; border-left-style: solid;">
<pre class="ecxk9mail">I tried xbuild from mono master as well as mono 3.2.8, and it *did* <br />complain about the syntax error you made. The output from master is:<br /><br />---------<br />atsushi:~/Desktop$ xbuild x.proj<br />XBuild Engine Version 12.0<br />Mono, Version <a href="http://4.3.0.0" target="_blank">4.3.0.0</a><br />Copyright (C) 2005-2013 Various Mono authors<br /><br />Build started 6/5/2015 2:08:48 AM.<br /><hr /><br />x.proj: error : /home/atsushi/Desktop/x.proj: Name cannot begin with the <br />' ' character, hexadecimal value 0x20. Line 1, position 2.<br />Build FAILED.<br />Errors:<br /><br />x.proj: error : /home/atsushi/Desktop/x.proj: Name cannot begin with the <br />' ' character, hexadecimal value 0x20. Line 1, position 2.<br /><br />      0 Warning(s)<br />      1 Error(s)<br /><br />Time Elapsed 00:00:00.0105090<br />---------<br /><br />Once I fixed the extraneous space between '<' and "Project", it printed <br />Hello world as expected:<br /><br
/>--------<br />atsushi:~/Desktop$ /usr/bin/xbuild x.proj<br />XBuild Engine Version 12.0<br />Mono, Version <a href="http://3.2.8.0" target="_blank">3.2.8.0</a><br />Copyright (C) 2005-2013 Various Mono authors<br /><br />Build started 6/5/2015 2:11:17 AM.<br /><hr /><br />Project "/home/atsushi/Desktop/x.proj" (default target(s)):<br />     Target Build:<br />         Hello, World!<br />Done building project "/home/atsushi/Desktop/x.proj".<br /><br />Build succeeded.<br />      0 Warning(s)<br />      0 Error(s)<br /><br />Time Elapsed 00:00:00.0708910<br />--------<br /><br />A precise repro steps would help inspecting possible bugs.<br /><br />Atsushi Eno<br /><br /><br />On 2015年06月03日 19:31, Cyd Haselton wrote:<br /><blockquote class="ecxgmail_quote" style="padding-left: 1ex; border-left-color: rgb(114, 159, 207); border-left-width: 1px; border-left-style: solid;"> Thing is xbuild doesn't even complain about the syntax errors in that <br /> project. It doesn't do
anything except for output version info then exit.<br /><br /> I'll
pastebin the file ifthe rebuild I;m working on doesn;t resolve <br /> the issue.<br /><br /> Thanks!<br /><br /> On June 3, 2015 6:18:11 AM CDT, Alan <alan.mcgovern@gmail.com> wrote:<br /><br />     Can you use a pastebin to attach the actual file you're trying to<br />     build? The text you attached has two syntax errors in it and would<br />     not work as-is.<br /><br />     A slightly modified file works as expected for me:<br />     <a href="https://gist.github.com/alanmcgovern/c2772a9cafd0d6a5b5ee" target="_blank">https://gist.github.com/alanmcgovern/c2772a9cafd0d6a5b5ee</a><br /><br />     Hope that helps!<br />     Alan<br /><br />     On 3 June 2015 at 11:54, Cyd Haselton <chaselton@gmail.com<br />     <mailto:chaselton@gmail.com>> wrote:<br /><br />         I did try xbuild /t:Build Pash.proj. Same result.<br /><br />         I will try the --trace xbuild after I rebuild mono again.<br /><br /><br />         On June 3, 2015 3:18:34 AM CDT, Alan
<alan.mcgovern@gmail.com<br />         <mailto:alan.mcgovern@gmail.com>> wrote:<br /><br />             You didn't tell xbuild to build anything and you didn't<br />             set a default target in your proj file.<br /><br />             Try `xbuild /t:Build Pash.proj`<br /><br />             On 2 June 2015 at 23:29, Alexander Köplinger<br />             <alex.koeplinger@outlook.com<br />             <mailto:alex.koeplinger@outlook.com>> wrote:<br /><br />                 Yeah, but it's much easier on another machine since we<br />                 got the official packages for Mono there :)<br /><br />                 Try running xbuild with "MONO_OPTIONS=--trace xbuild"<br />                 to show if/what it does before it exits.<br /><br /><br /><br /><hr /><br />                 Subject: RE: [Mono-dev] mono 4.0.0 xbuild won't build<br />                 project<br />                 From: chaselton@gmail.com <mailto:chaselton@gmail.com><br /> 
               Date: Tue, 2 Jun 2015 17:15:14 -0500<br />                 To: alex.koeplinger@outlook.com<br />                 <mailto:alex.koeplinger@outlook.com>;<br />                 mono-devel-list@lists.ximian.com<br />                 <mailto:mono-devel-list@lists.ximian.com><br /><br /><br />                 Excellent point.<br /><br />                 Then again...i'd have to install mono on another<br />                 machine. Also, I kinda would like to figure out why<br />                 xbuild is misbehaving on this one...<br /><br />                 On June 2, 2015 5:04:07 PM CDT, "Alexander Köplinger"<br />                 <alex.koeplinger@outlook.com<br />                 <mailto:alex.koeplinger@outlook.com>> wrote:<br /><br />                     No idea about the xbuild issue, but you should be<br />                     able to build Pash on another machine and just<br />                     copy over the .exe, it is managed code after
all ;)<br /><br /><br /><hr /><br />                     From: chaselton@gmail.com <mailto:chaselton@gmail.com><br />                     Date: Tue, 2 Jun 2015 16:54:19 -0500<br />                     To: mono-devel-list@lists.ximian.com<br />                     <mailto:mono-devel-list@lists.ximian.com><br />                     Subject: [Mono-dev] mono 4.0.0 xbuild won't build<br />                     project<br /><br />                     Just built and installed mono 4.0 from sources.<br />                     Basic "Hello World" console program builds and<br />                     runs successfully but basic "Hello World" project<br />                     (hello.proj) won't build; xbuild displays the<br />                     banner and then exits with no errors and without<br />                     building the project.<br /><br />                     Here's the hello.proj<br />                     < Project<br />                     xmlns="<a
href="http://schemas.microsoft.com/developer/msbuild/2003" target="_blank">http://schemas.microsoft.com/developer/msbuild/2003</a>"><br />                     <<a href="http://schemas.microsoft.com/developer/msbuild/2003%22%3e" target="_blank">http://schemas.microsoft.com/developer/msbuild/2003%22%3e</a>>;<br />                     <Target Name="Build"><br />                     <Message Importance="High" Text="Hello, World!" /><br />                     </Target><br />                     </Project><br /><br />                     I;ve tried /verbosity:detailed and several other<br />                     flags. I've tried running path/to/mono -v<br />                     /path/to/xbuild.exe proj.proj. Same thing happens<br />                     every time:<br /><br />                     /bld/pash/Pash-Project-Pash-bc07215 $ xbuild Pash.proj<br />                     XBuild Engine Version 12.0<br />                     Mono, Version <a
href="http://4.0.0.0" target="_blank">4.0.0.0</a> <<a href="http://4.0.0.0" target="_blank">http://4.0.0.0</a>><br />                     Copyright (C) 2005-2013 Various Mono authors<br />                     /bld/pash/Pash-Project-Pash-bc07215 $<br /><br />                     Please help...this is driving me crazy.<br /><br /><br />                 -- <br />                 Sent from my Android device with K-9 Mail. Please<br />                 excuse my brevity.<br /><br /><hr /><br />                 Mono-devel-list mailing list<br />                 Mono-devel-list@lists.ximian.com<br />                 <mailto:Mono-devel-list@lists.ximian.com><br />                 <a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br /><br /><br /><br />         -- <br />         Sent from my Android device with K-9 Mail. Please excuse my<br />         brevity.<br /><br /><br /><br /> --
<br /> Sent from my Android device with K-9 Mail. Please excuse my brevity.<br /><br /><br /><hr /><br /> Mono-devel-list mailing list<br /> Mono-devel-list@lists.ximian.com<br /> <a href="http://lists.ximian.com/mailman/listinfo/mono-devel-list" target="_blank">http://lists.ximian.com/mailman/listinfo/mono-devel-list</a><br /></blockquote><br /></pre></blockquote></div><br /></div></div></div></blockquote></div><br /></div></div></blockquote></div><br>
-- <br>
Sent from my Android device with K-9 Mail. Please excuse my brevity.</body></html>