<html><head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /></head><body style='font-size: 10pt; font-family: Verdana,Geneva,sans-serif'>
<p>Hello Alex.</p>
<p>I have followed those instructions and done a dist-upgrade, but after re-compiling with mcs the problem persists unchanged. I have the following versions now:</p>
<p>[11:38:29][blindcoder@flora:~/Downloads/PZ/MapMap]$ mcs --version<br />Mono C# compiler version 4.0.1.0<br />[11:38:34][blindcoder@flora:~/Downloads/PZ/MapMap]$ mono --version<br />Mono JIT compiler version 4.0.1 (tarball Thu May 28 09:08:28 UTC 2015)<br />Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com<br />    TLS:           __thread<br />    SIGSEGV:       altstack<br />    Notifications: epoll<br />    Architecture:  amd64<br />    Disabled:      none<br />    Misc:          softdebug <br />    LLVM:          supported, not enabled.<br />    GC:            sgen<br />[11:38:37][blindcoder@flora:~/Downloads/PZ/MapMap]$ cli --version<br />Mono JIT compiler version 4.0.1 (tarball Thu May 28 09:08:28 UTC 2015)<br />Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com<br />    TLS:           __thread<br />    SIGSEGV:       altstack<br />    Notifications: epoll<br />    Architecture:  amd64<br />    Disabled:      none<br />    Misc:          softdebug <br />    LLVM:          supported, not enabled.<br />    GC:            sgen</p>
<p>Kind regards,<br />Benjamin</p>
<p>Am 2015-06-09 11:07, schrieb Alexander Köplinger:</p>
<blockquote type="cite" style="padding: 0 0.4em; border-left: #1010ff 2px solid; margin: 0"><!-- html ignored --> <!-- head ignored --><!-- meta ignored -->
<div dir="ltr"><span style="color: #000000; font-family: Calibri,sans-serif;">It works fine here with latest Mono 4.0.1.44 on Ubuntu. Can you try upgrading to latest Mono from Xamarin by following <a href="http://www.mono-project.com/docs/getting-started/install/linux/#debian-ubuntu-and-derivatives">http://www.mono-project.com/docs/getting-started/install/linux/#debian-ubuntu-and-derivatives</a> ?</span><br /> <br />I suspect this has something to do with libgdiplus (the native library most of the System.Drawing code calls into).<br /> <br />-- Alex<br /> <br />
<div>> To: mono-devel-list@lists.ximian.com<br />> Date: Tue, 9 Jun 2015 10:15:02 +0200<br />> From: benjamin@anderdonau.de<br />> Subject: [Mono-dev] Problem with PNG transparancy on current Debian Unstable<br />> <br />> Hello.<br />> <br />> I have a problem with PNG transparancy in mono on current Debian <br />> Unstable.<br />> I created a small example (4 kB download) with minimal code and two <br />> example images:<br />> https://oc.anderdonau.de/index.php/s/VwTAlcjETG6j3XP<br />> <br />> Running this example on a current Debian Unstable results in this - bad <br />> - image:<br />> https://oc.anderdonau.de/index.php/s/AtVtba0tpSk4bn8<br />> <br />> Running the same code on an old Debian Squeeze (on armel) results in <br />> this - correct - image:<br />> https://oc.anderdonau.de/index.php/s/eqhmXh9qpBbg0WW<br />> <br />> Can someone help me with this issue?<br />> <br />> <br />> Kind regards,<br />> Benjamin<br />> -- <br />> Jabber: blindcoder@jabber.ccc.de<br />> Twitter: https://twitter.com/blind_coder<br />> Web: http://www.benjamin-schieder.de/<br />> _______________________________________________<br />> Mono-devel-list mailing list<br />> Mono-devel-list@lists.ximian.com<br />> http://lists.ximian.com/mailman/listinfo/mono-devel-list</div>
</div>
</blockquote>
<p> </p>
<div>
<div class="pre" style="margin: 0; padding: 0; font-family: monospace">Jabber: <a href="mailto:blindcoder@jabber.ccc.de">blindcoder@jabber.ccc.de</a><br /> Twitter: <a href="https://twitter.com/blind_coder" target="_blank" rel="noreferrer">https://twitter.com/blind_coder</a><br /> Web: <a href="http://www.benjamin-schieder.de/" target="_blank" rel="noreferrer">http://www.benjamin-schieder.de/</a></div>
</div>
</body></html>